Project

General

Profile

Cannot download list on new v4 install ?

Added by David Puckett 5 months ago

Hi,
I'm new here and I recently installed GoAutoDial v4 from scratch on Centos 7 and almost everything appears to be working except 1 issue.
I created and uploaded to the list and the list was successfully updated with phone numbers/contacts in it however when trying to select this list and download it back it's giving this error:

"Failed to Process Request... Please inform the administrator."

Please help with this issue I need to be able to download the lists again at some point to check dial status on them, etc.
How can I best fix this?

Thank you for anyone's assistance and time they can spare on this would be greatly appreciated and if need anything else from me to help figure this out please let me know I'll provide anything needed.


Replies (7)

RE: Cannot download list on new v4 install ? - Added by Wittie Manansala 4 months ago

Hi,

Try to update your server with latest using this link https://goautodial.org/projects/goautodialce/wiki/HOWTO_Update_latest_version_via_Github and if you still encountering issue please provide us screenshot with console for us to review.

Thanks

RE: Cannot download list on new v4 install ? - Added by Leopoldo Martinez 4 months ago

David Puckett wrote:

Hi,
I'm new here and I recently installed GoAutoDial v4 from scratch on Centos 7 and almost everything appears to be working except 1 issue.
I created and uploaded to the list and the list was successfully updated with phone numbers/contacts in it however when trying to select this list and download it back it's giving this error:

"Failed to Process Request... Please inform the administrator."

Please help with this issue I need to be able to download the lists again at some point to check dial status on them, etc.
How can I best fix this?

Thank you for anyone's assistance and time they can spare on this would be greatly appreciated and if need anything else from me to help figure this out please let me know I'll provide anything needed.

Hi, do not update to the latest version, it will give you more problems (I did it and was bad idea to do it) what i did was instal goautodial and update it via git hub but to this commit feb 24, commit ee18ea557eaee4fbf896edbffc57989d7bfed077, and is working perfectly.

RE: Cannot download list on new v4 install ? - Added by Jackie Alfonso 4 months ago

Leopoldo Martinez wrote in RE: Cannot download list on new v4 install ?:

David Puckett wrote:

Hi,
I'm new here and I recently installed GoAutoDial v4 from scratch on Centos 7 and almost everything appears to be working except 1 issue.
I created and uploaded to the list and the list was successfully updated with phone numbers/contacts in it however when trying to select this list and download it back it's giving this error:

"Failed to Process Request... Please inform the administrator."

Please help with this issue I need to be able to download the lists again at some point to check dial status on them, etc.
How can I best fix this?

Thank you for anyone's assistance and time they can spare on this would be greatly appreciated and if need anything else from me to help figure this out please let me know I'll provide anything needed.

Hi, do not update to the latest version, it will give you more problems (I did it and was bad idea to do it) what i did was instal goautodial and update it via git hub but to this commit feb 24, commit ee18ea557eaee4fbf896edbffc57989d7bfed077, and is working perfectly.

Hi,

Can you please list down the issue that you've encountered so we can verify.

Thanks!

RE: Cannot download list on new v4 install ? - Added by Leopoldo Martinez 4 months ago

Jackie Alfonso wrote in RE: Cannot download list on new v4 install ?:

Leopoldo Martinez wrote in RE: Cannot download list on new v4 install ?:

David Puckett wrote:

Hi,
I'm new here and I recently installed GoAutoDial v4 from scratch on Centos 7 and almost everything appears to be working except 1 issue.
I created and uploaded to the list and the list was successfully updated with phone numbers/contacts in it however when trying to select this list and download it back it's giving this error:

"Failed to Process Request... Please inform the administrator."

Please help with this issue I need to be able to download the lists again at some point to check dial status on them, etc.
How can I best fix this?

Thank you for anyone's assistance and time they can spare on this would be greatly appreciated and if need anything else from me to help figure this out please let me know I'll provide anything needed.

Hi, do not update to the latest version, it will give you more problems (I did it and was bad idea to do it) what i did was instal goautodial and update it via git hub but to this commit feb 24, commit ee18ea557eaee4fbf896edbffc57989d7bfed077, and is working perfectly.

Hi,

Can you please list down the issue that you've encountered so we can verify.

Thanks!

Sure.

Can't download list
can't dowload recordings
can't monitoring (barge, whisper and listen are disabled)
Calls have many bugs
Asterisk crash constantly

All seems like the whatsapp module is giving too many errors

RE: Cannot download list on new v4 install ? - Added by emilio gorky 3 months ago

Can confirm that is not possible to download the list. I have installed Goautodial several times to confirm and is not working. I am using the commit 6b84cd4e17fc998b5815c57a96390fef4ebc455e

and the commit 7747b8c69e344d32ab1540ad43e0009ad6a69348

for the API.
Here you can see I am trying to download it

and then, the error:

I've checked the file permissions and is not the problem:

The system is up to date to the last commit on march 30th 2021.
I have tried reinstalling the whole server but to no avail.

RE: Cannot download list on new v4 install ? - Added by emilio gorky 3 months ago

OK, in case anyone faces the same problem, I have found the culprit, and it is the commit f8adaeb325b4138803ee3147d5ae57b4f0156990 made to the php/ExportList.php file on dec 2020. The modification can be seen in https://github.com/goautodial/v4.0/commit/f8adaeb325b4138803ee3147d5ae57b4f0156990?branch=f8adaeb325b4138803ee3147d5ae57b4f0156990&diff=split . What one needs to do is uncomment lines 28 and 59 and comment from line 60 to 113. That's it!

    (1-7/7)
    Go to top