Project

General

Profile

One way audio on SRTP calls after ~35 minutes

Added by Enzo Zazzaro 4 months ago

Hello,
after about 35 minutes the audio is no longer recursive only audio output but nothing input. I speak of 10 operator CALLCENTER so in production I think it is a problem of KERNEL RTPENGINE on a forum they had the same problem and they solved with a patch on the rtp kernel

https://github.com/sipwise/rtpengine/issues/917

if you can please give me some advice on how to modify the rtp kernel. The system is fully functional but with this problem we are unable to work.


Replies (13)

RE: One way audio on SRTP calls after ~35 minutes - Added by Enzo Zazzaro 3 months ago

my solution is
NAT=yes
in carrier and in sip-goautodial.conf

RE: One way audio on SRTP calls after ~35 minutes - Added by Enzo Zazzaro 3 months ago

Enzo Zazzaro wrote:

my solution is
NAT=yes
in carrier and in sip-goautodial.conf

in VPS contabo and voip in albany is not nat but witch nat=yes is ok

RE: One way audio on SRTP calls after ~35 minutes - Added by Enzo Zazzaro 3 months ago

it does not work after 3 - 4 calls, it is no longer heard.
kamailio and astersisk work and have no errors I think it's a "keep alive" problem on kamailio that I don't see in the kamailio.cfg file is someone testing it? Are you experiencing the same problem? both outgoing and incoming

RE: One way audio on SRTP calls after ~35 minutes - Added by Demian Lizandro Biscocho 3 months ago

Sounds like some NAT/firewall issues. Does your server have a public IP or is it behind a firewall?

The following ports need to be opened(or forwarded to your server):

TCP: 80, 443, 4443
UDP: 5060, 5066, 10k to 65535.

RE: One way audio on SRTP calls after ~35 minutes - Added by Enzo Zazzaro 3 months ago

firewall is open and server in CONTABO VPS
everything is working but it happens that every now and then the xlite call ends and you have to log back to resume the call.
kamailio:
tls: v1.2 +
certified letencript
; Rtptimeout =

RE: One way audio on SRTP calls after ~35 minutes - Added by Wittie Manansala 3 months ago

Hi,

Which of the two guides below you've used to enable softphone registration?

a. https://goautodial.org/projects/goautodialce/wiki/HOWTO_Enable_Softphones

b. https://goautodial.org/projects/goautodialce/wiki/HOWTO_Enable_Softphones_Registration_per_User

Are you experiencing same issue even webrtc is enabled? did you install any card or 3rd party up?

Thanks

RE: One way audio on SRTP calls after ~35 minutes - Added by Enzo Zazzaro 2 months ago

my system is OK
KAMAILIO OK
RTPENGINE OK
ASTERISK OK
TLS OK
SYSTEM OK AND they work

System CALL and agent working but sometimes konference call is mute and after one call with audio next call is muted. i logout agent and relogin and confenrze is mute i reboot server and all is OK .
agent job normally
i send
systemctl restart rtpengine
systemctl restart asterisk
systemctl restart kamailio

but only reboot resolv this problem

RE: One way audio on SRTP calls after ~35 minutes - Added by Demian Lizandro Biscocho 2 months ago

Is this happening on outbound calls or inbound?

RE: One way audio on SRTP calls after ~35 minutes - Added by Enzo Zazzaro 2 months ago

outbound and inbound but i not have audio konference when relogin agent and only solution is reboot.For me problem is on port not dissocian the port on audio/asterisk and system not view the disconnession.
i check all
system is ok and whitch 10 agent is ok mobile/desktop but this problem occurs on one agent i reboot and all ok.

RE: One way audio on SRTP calls after ~35 minutes - Added by Wittie Manansala 2 months ago

Hi,

If one agent only experiencing the issue try to check the following:

1. Agent workstation
*You might also need to check the agents workstations to see if they're not overloaded. Meaning they're just running the necessary applications for dialing (Chrome, notepad, or application required for dialing). Re-schedule system update like windows update and antivirus update.

2. Workstation Internet Connection
*Make sure workstation is using wired connection or connected using LAN cable

3. Bandwidth Consumption
*Might be eating all your connections. Make sure your internet connectivity is just being used for dialing purposes. Browsing social media sites like Facebook, Google+ and Youtube and others will eat up all your bandwidth.

4. Latency
*Most of the time it's the stability of the internet connection (latency issues). A stable network is more important when it comes to VoIP traffic and data. Latency has the reputation of being the enemy of VoIP and data. Average latency should be less than 200ms

For Troubleshooting:

Try to switch that agent to softphone registration just simply follow the steps posted here https://goautodial.org/projects/goautodialce/wiki/HOWTO_Enable_Softphones_Registration_per_User

Thanks

RE: One way audio on SRTP calls after ~35 minutes - Added by Abdullah Al Mamun about 1 month ago

Had same issue. First call is always problem free and smooth.
One way audio starts after random time.
Later client switched to 3cx.

RE: One way audio on SRTP calls after ~35 minutes - Added by Wittie Manansala about 1 month ago

Hi,

You reply:
system is ok and whitch 10 agent is ok mobile/desktop but this problem occurs on one agent i reboot and all ok.

Same issue on one agent? Are all your agents are in same network or office?

Try also to switch the said agent to softphone.
Wiki: https://goautodial.org/projects/goautodialce/wiki/HOWTO_Enable_Softphones_Registration_per_User

Thanks

    (1-13/13)
    Go to top