Project

General

Profile

FastAGI not working

Added by Jorge Cornejo 4 months ago

Hi
I have installed on a EC2 instance and so far I can log the extension.
Kamailio already works after editing these files:


nano /etc/kamailio/kamctlrc
SIP_DOMAIN=subdomain.domain.com

nano /etc/kamailio/kamailio.cfg
/* add local domain aliases */
#alias="172.31.14.56" 
alias="subdomain.domain.com" 

# kamctl restart

But now I get an RTP Timeout error.

At Asterisk I see this error:

-- Called 99995505791853@default -- Executing [99995505791853@default:1] Dial("Local/99995505791853@default-00000002;2", "SIP/5505791853@kamailio,,tTo") in new stack == Using SIP RTP CoS mark 5 -- Called SIP/5505791853@kamailio -- SIP/kamailio-00000001 is ringing -- Local/99995505791853@default-00000002;1 is ringing > 0x7fa4c8002890 -- Strict RTP learning after remote address set to: 172.31.14.56:30046 -- SIP/kamailio-00000001 answered Local/99995505791853@default-00000002;2 -- Local/99995505791853@default-00000002;1 answered -- Channel SIP/kamailio-00000001 joined 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4> == Manager 'sendcron' logged off from 127.0.0.1 -- Executing [8600051@default:1] Konference("Local/99995505791853@default-00000002;1", "8600051,R") in new stack -- Channel Local/99995505791853@default-00000002;2 joined 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4> [Mar 8 16:43:33] WARNING[5133][C-00000004]: file.c:774 ast_openstream_full: File confbridge-join does not exist in any format -- Channel SIP/kamailio-00000001 left 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4> -- Channel Local/99995505791853@default-00000002;2 left 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4> == Spawn extension (default, 99995505791853, 1) exited non-zero on 'Local/99995505791853@default-00000002;2' -- Executing [h@default:1] AGI("Local/99995505791853@default-00000002;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)") in new stack [Mar 8 16:43:45] WARNING[5134][C-00000003]: res_agi.c:2038 handle_connection: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)': Connection refused [Mar 8 16:43:45] WARNING[5134][C-00000003]: res_agi.c:2110 launch_netscript: Couldn't connect to any host. FastAGI failed. [Mar 8 16:43:45] WARNING[5133][C-00000004]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel -- Executing [h@default:1] AGI("Local/99995505791853@default-00000002;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack [Mar 8 16:43:45] WARNING[5133][C-00000004]: res_agi.c:2038 handle_connection: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused [Mar 8 16:43:45] WARNING[5133][C-00000004]: res_agi.c:2110 launch_netscript: Couldn't connect to any host. FastAGI failed. == Manager 'sendcron' logged on from 127.0.0.1 [Mar 8 16:43:45] NOTICE[5162]: manager.c:4309 action_hangup: Request to hangup non-existent channel: Local/99995505791853@default-00000002;2 == Manager 'sendcron' logged off from 127.0.0.1 == Manager 'sendcron' logged on from 127.0.0.1 -- Called 55558600051@default -- Executing [55558600051@default:1] Hangup("Local/55558600051@default-00000003;2", "") in new stack == Spawn extension (default, 55558600051, 1) exited non-zero on 'Local/55558600051@default-00000003;2' [Mar 8 16:43:45] WARNING[5165][C-00000005]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel -- Executing [h@default:1] AGI("Local/55558600051@default-00000003;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack [Mar 8 16:43:45] WARNING[5165][C-00000005]: res_agi.c:2038 handle_connection: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused [Mar 8 16:43:45] WARNING[5165][C-00000005]: res_agi.c:2110 launch_netscript: Couldn't connect to any host. FastAGI failed.

So if I do a netstat -an can't see anything working at port 4577. What should I do to start the FASTAGI port or what is supposed to be listening to that port?

At my subdomain, do I need to setup DNS for sip like _sip._udp and _sip._tcp?


Replies (22)

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

  == Manager 'sendcron' logged on from 127.0.0.1
    -- Called 99995505791853@default
    -- Executing [99995505791853@default:1] Dial("Local/99995505791853@default-00000002;2", "SIP/5505791853@kamailio,,tTo") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/5505791853@kamailio
    -- SIP/kamailio-00000001 is ringing
    -- Local/99995505791853@default-00000002;1 is ringing
       > 0x7fa4c8002890 -- Strict RTP learning after remote address set to: 172.31.14.56:30046
    -- SIP/kamailio-00000001 answered Local/99995505791853@default-00000002;2
    -- Local/99995505791853@default-00000002;1 answered
    -- Channel SIP/kamailio-00000001 joined 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4>
  == Manager 'sendcron' logged off from 127.0.0.1
    -- Executing [8600051@default:1] Konference("Local/99995505791853@default-00000002;1", "8600051,R") in new stack
    -- Channel Local/99995505791853@default-00000002;2 joined 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4>
[Mar  8 16:43:33] WARNING[5133][C-00000004]: file.c:774 ast_openstream_full: File confbridge-join does not exist in any format
    -- Channel SIP/kamailio-00000001 left 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4>
    -- Channel Local/99995505791853@default-00000002;2 left 'simple_bridge' basic-bridge <6e3eb18e-cc42-49cb-b766-79d0361471c4>
  == Spawn extension (default, 99995505791853, 1) exited non-zero on 'Local/99995505791853@default-00000002;2'
    -- Executing [h@default:1] AGI("Local/99995505791853@default-00000002;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)") in new stack
[Mar  8 16:43:45] WARNING[5134][C-00000003]: res_agi.c:2038 handle_connection: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)': Connection refused
[Mar  8 16:43:45] WARNING[5134][C-00000003]: res_agi.c:2110 launch_netscript: Couldn't connect to any host.  FastAGI failed.
[Mar  8 16:43:45] WARNING[5133][C-00000004]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
    -- Executing [h@default:1] AGI("Local/99995505791853@default-00000002;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar  8 16:43:45] WARNING[5133][C-00000004]: res_agi.c:2038 handle_connection: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused
[Mar  8 16:43:45] WARNING[5133][C-00000004]: res_agi.c:2110 launch_netscript: Couldn't connect to any host.  FastAGI failed.
  == Manager 'sendcron' logged on from 127.0.0.1
[Mar  8 16:43:45] NOTICE[5162]: manager.c:4309 action_hangup: Request to hangup non-existent channel: Local/99995505791853@default-00000002;2
  == Manager 'sendcron' logged off from 127.0.0.1
  == Manager 'sendcron' logged on from 127.0.0.1
    -- Called 55558600051@default
    -- Executing [55558600051@default:1] Hangup("Local/55558600051@default-00000003;2", "") in new stack
  == Spawn extension (default, 55558600051, 1) exited non-zero on 'Local/55558600051@default-00000003;2'
[Mar  8 16:43:45] WARNING[5165][C-00000005]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
    -- Executing [h@default:1] AGI("Local/55558600051@default-00000003;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar  8 16:43:45] WARNING[5165][C-00000005]: res_agi.c:2038 handle_connection: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused
[Mar  8 16:43:45] WARNING[5165][C-00000005]: res_agi.c:2110 launch_netscript: Couldn't connect to any host.  FastAGI failed.

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

Don't quite know what this does but posting as seems something asked for TB:

[root@edialer1 etc]# screen -list
There are screens on:
        4858.ASTVDadapt (Detached)
        4855.ASTVDremote        (Detached)
        4852.ASTVDauto  (Detached)
        4849.ASTlisten  (Detached)
        4846.ASTsend    (Detached)
        4843.ASTupdate  (Detached)
        4688.asterisk   (Detached)
7 Sockets in /var/run/screen/S-root.

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

Edited /etc/asterisk/sip-goautodial.conf:

host=vaglxc01.goautodial.com ;change me to my FQDN

Now the Kamailio at least shows registering from the proper domain, but still No RTP available error at WebRTC Agent frontend...

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

Still Asterisk complains:


[Mar 12 16:33:53] WARNING[5148][C-00000002] res_agi.c: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused
[Mar 12 16:33:53] WARNING[5148][C-00000002] res_agi.c: Couldn't connect to any host.  FastAGI failed.

How to fix this??

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

[root@edialer1 astguiclient]# screen -list
There are screens on:
        14889.asterisk  (Detached)
        12081.pts-8.edialer1    (Attached)
        4862.ASTVDadapt (Detached)
        4859.ASTVDremote        (Detached)
        4856.ASTVDauto  (Detached)
        4853.ASTlisten  (Detached)
        4850.ASTsend    (Detached)
        4847.ASTupdate  (Detached)
        4702.asterisk   (Detached)
9 Sockets in /var/run/screen/S-root.

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

[Mar 12 17:58:20] VERBOSE[15330] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 17:58:20] VERBOSE[15331] dial.c: Called 99992347600834@default
[Mar 12 17:58:20] VERBOSE[15332][C-00000006] pbx.c: Executing [99992347600834@default:1] Dial("Local/99992347600834@default-00000004;2", "SIP/2347600834@kamailio,,tTo") in new stack
[Mar 12 17:58:20] VERBOSE[15332][C-00000006] netsock2.c: Using SIP RTP CoS mark 5
[Mar 12 17:58:20] VERBOSE[15332][C-00000006] app_dial.c: Called SIP/2347600834@kamailio
[Mar 12 17:58:20] VERBOSE[15332][C-00000006] app_dial.c: SIP/kamailio-00000002 is ringing
[Mar 12 17:58:20] VERBOSE[15331] dial.c: Local/99992347600834@default-00000004;1 is ringing
[Mar 12 17:58:20] VERBOSE[4811][C-00000006] res_rtp_asterisk.c: 0x7f86b400c820 -- Strict RTP learning after remote address set to: 172.31.14.56:30086
[Mar 12 17:58:20] VERBOSE[15332][C-00000006] app_dial.c: SIP/kamailio-00000002 answered Local/99992347600834@default-00000004;2
[Mar 12 17:58:20] VERBOSE[15331] dial.c: Local/99992347600834@default-00000004;1 answered
[Mar 12 17:58:20] VERBOSE[15331][C-00000007] pbx.c: Executing [8600051@default:1] Konference("Local/99992347600834@default-00000004;1", "8600051,R") in new stack
[Mar 12 17:58:20] VERBOSE[15330] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 17:58:20] VERBOSE[15334][C-00000006] bridge_channel.c: Channel SIP/kamailio-00000002 joined 'simple_bridge' basic-bridge <62f379bf-4261-445f-ae4b-5f6ea35424ca>
[Mar 12 17:58:20] VERBOSE[15332][C-00000006] bridge_channel.c: Channel Local/99992347600834@default-00000004;2 joined 'simple_bridge' basic-bridge <62f379bf-4261-445f-ae4b-5f6ea35424ca>
[Mar 12 17:58:23] WARNING[15331][C-00000007] file.c: File confbridge-join does not exist in any format
[Mar 12 17:58:35] VERBOSE[15334][C-00000006] bridge_channel.c: Channel SIP/kamailio-00000002 left 'simple_bridge' basic-bridge <62f379bf-4261-445f-ae4b-5f6ea35424ca>
[Mar 12 17:58:35] VERBOSE[15332][C-00000006] bridge_channel.c: Channel Local/99992347600834@default-00000004;2 left 'simple_bridge' basic-bridge <62f379bf-4261-445f-ae4b-5f6ea35424ca>
[Mar 12 17:58:35] VERBOSE[15332][C-00000006] pbx.c: Spawn extension (default, 99992347600834, 1) exited non-zero on 'Local/99992347600834@default-00000004;2'
[Mar 12 17:58:35] VERBOSE[15332][C-00000006] pbx.c: Executing [h@default:1] AGI("Local/99992347600834@default-00000004;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)") in new stack
[Mar 12 17:58:35] WARNING[15332][C-00000006] res_agi.c: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)': Connection refused
[Mar 12 17:58:35] WARNING[15332][C-00000006] res_agi.c: Couldn't connect to any host.  FastAGI failed.
[Mar 12 17:58:35] WARNING[15331][C-00000007] func_hangupcause.c: Unable to find information for channel
[Mar 12 17:58:35] VERBOSE[15331][C-00000007] pbx.c: Executing [h@default:1] AGI("Local/99992347600834@default-00000004;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 12 17:58:35] WARNING[15331][C-00000007] res_agi.c: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused
[Mar 12 17:58:35] WARNING[15331][C-00000007] res_agi.c: Couldn't connect to any host.  FastAGI failed.
[Mar 12 17:58:35] VERBOSE[15373] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 17:58:36] NOTICE[15373] manager.c: Request to hangup non-existent channel: Local/99992347600834@default-00000004;2
[Mar 12 17:58:36] VERBOSE[15373] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 17:58:36] VERBOSE[15374] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 17:58:36] VERBOSE[15375] dial.c: Called 55558600051@default
[Mar 12 17:58:36] VERBOSE[15376][C-00000008] pbx.c: Executing [55558600051@default:1] Hangup("Local/55558600051@default-00000005;2", "") in new stack
[Mar 12 17:58:36] VERBOSE[15376][C-00000008] pbx.c: Spawn extension (default, 55558600051, 1) exited non-zero on 'Local/55558600051@default-00000005;2'
[Mar 12 17:58:36] WARNING[15376][C-00000008] func_hangupcause.c: Unable to find information for channel
[Mar 12 17:58:36] VERBOSE[15376][C-00000008] pbx.c: Executing [h@default:1] AGI("Local/55558600051@default-00000005;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 12 17:58:36] WARNING[15376][C-00000008] res_agi.c: Connecting to '127.0.0.1:4577' failed for url 'agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)': Connection refused
[Mar 12 17:58:36] WARNING[15376][C-00000008] res_agi.c: Couldn't connect to any host.  FastAGI failed.
[Mar 12 17:58:36] VERBOSE[15374] manager.c: Manager 'sendcron' logged off from 127.0.0.1

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

Seems found the root problem...a missing lib?

[root@edialer1 astguiclient]#
[root@edialer1 astguiclient]# [root@edialer1 astguiclient]# /usr/share/astguiclient/FastAGI_log.pl --debug
bash: [root@edialer1: command not found
[root@edialer1 astguiclient]# Can't locate Net/Server.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/astguiclient/FastAGI_log.pl line 177.
> BEGIN failed--compilation aborted at /usr/share/astguiclient/FastAGI_log.pl line 177.
> ^C
[root@edialer1 astguiclient]#

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

Ok
Fixed those with, missing steps from Wiki...

yum install cpan
cpan install Net::Server
cpan install Asterisk::AGI

Now my problem is:


[Mar 12 18:29:01] VERBOSE[4985] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:29:01] VERBOSE[4985] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 18:29:03] VERBOSE[5033] manager.c: Manager 'updatecron' logged on from 127.0.0.1
[Mar 12 18:29:03] VERBOSE[5034] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:29:03] VERBOSE[5035] dial.c: Called 99992347600834@default
[Mar 12 18:29:03] VERBOSE[5036][C-00000000] pbx.c: Executing [99992347600834@default:1] Dial("Local/99992347600834@default-00000000;2", "SIP/2347600834@kamailio,,tTo") in new stack
[Mar 12 18:29:03] VERBOSE[5036][C-00000000] netsock2.c: Using SIP RTP CoS mark 5
[Mar 12 18:29:03] VERBOSE[5036][C-00000000] app_dial.c: Called SIP/2347600834@kamailio
[Mar 12 18:29:03] VERBOSE[5044] manager.c: Manager 'listencron' logged on from 127.0.0.1
[Mar 12 18:29:03] VERBOSE[5036][C-00000000] app_dial.c: SIP/kamailio-00000000 is ringing
[Mar 12 18:29:03] VERBOSE[5035] dial.c: Local/99992347600834@default-00000000;1 is ringing
[Mar 12 18:29:03] VERBOSE[4901][C-00000000] res_rtp_asterisk.c: 0x7fd79400a4d0 -- Strict RTP learning after remote address set to: 172.31.14.56:30012
[Mar 12 18:29:03] VERBOSE[5036][C-00000000] app_dial.c: SIP/kamailio-00000000 answered Local/99992347600834@default-00000000;2
[Mar 12 18:29:03] VERBOSE[5035] dial.c: Local/99992347600834@default-00000000;1 answered
[Mar 12 18:29:03] VERBOSE[5035][C-00000001] pbx.c: Executing [8600051@default:1] Konference("Local/99992347600834@default-00000000;1", "8600051,R") in new stack
[Mar 12 18:29:03] VERBOSE[5034] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 18:29:03] VERBOSE[5045][C-00000000] bridge_channel.c: Channel SIP/kamailio-00000000 joined 'simple_bridge' basic-bridge <e1556be1-068d-4dea-a16d-a313a07ed6f9>
[Mar 12 18:29:03] VERBOSE[5036][C-00000000] bridge_channel.c: Channel Local/99992347600834@default-00000000;2 joined 'simple_bridge' basic-bridge <e1556be1-068d-4dea-a16d-a313a07ed6f9>
[Mar 12 18:29:06] WARNING[5035][C-00000001] file.c: File confbridge-join does not exist in any format
[Mar 12 18:29:06] VERBOSE[5057] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:29:06] VERBOSE[5057] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 18:29:18] VERBOSE[5045][C-00000000] bridge_channel.c: Channel SIP/kamailio-00000000 left 'simple_bridge' basic-bridge <e1556be1-068d-4dea-a16d-a313a07ed6f9>
[Mar 12 18:29:18] VERBOSE[5036][C-00000000] bridge_channel.c: Channel Local/99992347600834@default-00000000;2 left 'simple_bridge' basic-bridge <e1556be1-068d-4dea-a16d-a313a07ed6f9>
[Mar 12 18:29:18] VERBOSE[5036][C-00000000] pbx.c: Spawn extension (default, 99992347600834, 1) exited non-zero on 'Local/99992347600834@default-00000000;2'
[Mar 12 18:29:18] VERBOSE[5036][C-00000000] pbx.c: Executing [h@default:1] AGI("Local/99992347600834@default-00000000;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK)") in new stack
[Mar 12 18:29:18] VERBOSE[5036][C-00000000] res_agi.c: <Local/99992347600834@default-00000000;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----15-----15-----SIP 200 OK) completed, returning 0
[Mar 12 18:29:18] WARNING[5035][C-00000001] func_hangupcause.c: Unable to find information for channel
[Mar 12 18:29:18] VERBOSE[5035][C-00000001] pbx.c: Executing [h@default:1] AGI("Local/99992347600834@default-00000000;1", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 12 18:29:18] VERBOSE[5035][C-00000001] res_agi.c: <Local/99992347600834@default-00000000;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------) completed, returning 0
[Mar 12 18:29:18] VERBOSE[5081] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:29:18] NOTICE[5081] manager.c: Request to hangup non-existent channel: Local/99992347600834@default-00000000;2
[Mar 12 18:29:18] VERBOSE[5081] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 18:29:18] VERBOSE[5082] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:29:18] VERBOSE[5083] dial.c: Called 55558600051@default
[Mar 12 18:29:18] VERBOSE[5084][C-00000002] pbx.c: Executing [55558600051@default:1] Hangup("Local/55558600051@default-00000001;2", "") in new stack
[Mar 12 18:29:18] VERBOSE[5084][C-00000002] pbx.c: Spawn extension (default, 55558600051, 1) exited non-zero on 'Local/55558600051@default-00000001;2'
[Mar 12 18:29:18] WARNING[5084][C-00000002] func_hangupcause.c: Unable to find information for channel
[Mar 12 18:29:18] VERBOSE[5084][C-00000002] pbx.c: Executing [h@default:1] AGI("Local/55558600051@default-00000001;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------)") in new stack
[Mar 12 18:29:18] VERBOSE[5084][C-00000002] res_agi.c: <Local/55558600051@default-00000001;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------) completed, returning 0
[Mar 12 18:29:18] VERBOSE[5082] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 18:30:02] VERBOSE[5155] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:30:02] VERBOSE[5155] manager.c: Manager 'sendcron' logged off from 127.0.0.1
[Mar 12 18:30:07] VERBOSE[5174] manager.c: Manager 'sendcron' logged on from 127.0.0.1
[Mar 12 18:30:07] VERBOSE[5174] manager.c: Manager 'sendcron' logged off from 127.0.0.1

Will keep digging, but if anyone has a clue pls let me know

RE: FastAGI not working - Added by Wittie Manansala 4 months ago

Hi,

Thanks for sharing.

May we know what error (or provide us the screenshot)show in your agent UI during that issue.

Thanks

RE: FastAGI not working - Added by Jorge Cornejo 4 months ago

Sure,
This is the error I am getting at agent GUI

RE: FastAGI not working - Added by Levy Ryan Nolasco 4 months ago

Hi,

Can you post all the entry on your sip-goautodial.conf and the value of rtptimeout on your sip.conf

RE: FastAGI not working - Added by Steve Turner 17 days ago

Having the same issue, however now says the port is in use and will not bind to 4577

[root@dialin ~]# /usr/share/astguiclient/FastAGI_log.pl --debug
2019/07/02-12:24:30 VDfastAGI (type Net::Server::PreFork) starting! pid(5024)
Resolved [*]:4577 to [0.0.0.0]:4577, IPv4
Binding to TCP port 4577 on host 0.0.0.0 with IPv4
2019/07/02-12:24:30 Can't connect to TCP port 4577 on 0.0.0.0 [Address already in use]
at line 68 in file /usr/share/perl5/vendor_perl/Net/Server/Proto/TCP.pm
2019/07/02-12:24:30 Server closing!
[root@dialin ~]# cat /etc/services | grep 4577
[root@dialin ~]# netstat -anp|grep :4577
tcp 0 0 0.0.0.0:4577 0.0.0.0:* LISTEN 4181/perl

RE: FastAGI not working - Added by Demian Lizandro Biscocho 17 days ago

Steve Turner wrote:

Having the same issue, however now says the port is in use and will not bind to 4577

[root@dialin ~]# /usr/share/astguiclient/FastAGI_log.pl --debug
2019/07/02-12:24:30 VDfastAGI (type Net::Server::PreFork) starting! pid(5024)
Resolved [*]:4577 to [0.0.0.0]:4577, IPv4
Binding to TCP port 4577 on host 0.0.0.0 with IPv4
2019/07/02-12:24:30 Can't connect to TCP port 4577 on 0.0.0.0 [Address already in use]
at line 68 in file /usr/share/perl5/vendor_perl/Net/Server/Proto/TCP.pm
2019/07/02-12:24:30 Server closing!
[root@dialin ~]# cat /etc/services | grep 4577
[root@dialin ~]# netstat -anp|grep :4577
tcp 0 0 0.0.0.0:4577 0.0.0.0:* LISTEN 4181/perl

This is the normal behavior since it's (/usr/share/astguiclient/FastAGI_log.pl) already running and using port 4577.

[root@gadcs ~]# screen -ls

There are screens on:
        5354.ASTVDremote        (Detached)
        7136.ASTVDadapt (Detached)
        782.ASTVDauto   (Detached)
        779.ASTlisten   (Detached)
        776.ASTsend     (Detached)
        773.ASTupdate   (Detached)
        576.ASTfastlog  (Detached)
        554.asterisk    (Detached)
8 Sockets in /var/run/screen/S-root.

[root@gadcs ~]# netstat -panut | grep 4577

tcp        0      0 0.0.0.0:4577            0.0.0.0:*               LISTEN      579/perl 

[root@localhost ~]# ps ax | grep perl

579 pts/10   Ss+    0:01 /usr/bin/perl /usr/share/astguiclient/FastAGI_log.pl --debug
616 pts/10 S+ 0:00 /usr/bin/perl /usr/share/astguiclient/FastAGI_log.pl --debug
617 pts/10 S+ 0:00 /usr/bin/perl /usr/share/astguiclient/FastAGI_log.pl --debug
661 pts/3 S 0:00 /usr/bin/perl /usr/local/bin/listener.pl
775 pts/2 Ss+ 6:07 /usr/bin/perl /usr/share/astguiclient/AST_update_AMI2.pl
778 pts/4 Ss+ 6:37 /usr/bin/perl /usr/share/astguiclient/AST_manager_send.pl
781 pts/5 Ss+ 0:59 /usr/bin/perl /usr/share/astguiclient/AST_manager_listen_AMI2.pl
784 pts/6 Ss+ 1:36 /usr/bin/perl /usr/share/astguiclient/AST_VDauto_dial.pl
3294 pts/10 S+ 0:00 /usr/bin/perl /usr/share/astguiclient/FastAGI_log.pl --debug
4124 pts/10 S+ 0:00 /usr/bin/perl /usr/share/astguiclient/FastAGI_log.pl --debug
5357 pts/7 Ss+ 0:02 /usr/bin/perl /usr/share/astguiclient/AST_VDremote_agents.pl --debug
7138 pts/8 Ss+ 6:01 /usr/bin/perl /usr/share/astguiclient/AST_VDadapt.pl --debug
10585 ? Ss 0:00 /usr/bin/perl /usr/share/astguiclient/AST_manager_kill_hung_congested.pl
10645 pts/0 S+ 0:00 grep --color=auto perl
19698 pts/10 S+ 0:00 /usr/bin/perl /usr/share/astguiclient/FastAGI_log.pl --debug

[root@localhost ~]#

RE: FastAGI not working - Added by Steve Turner 17 days ago

The issue is that when i try to login and register phone, asterisk is trying to INVITE using the CALLERID number of the campaign <sip::5070>, and gives error SIP 407 Proxy Authentication Required.

Manager 'sendcron' logged on from 127.0.0.1
-- Called 99992900827243@default
-- Executing [99992900827243@default:1] Dial("Local/99992900827243@default-00000000;2", "SIP/2900827243@kamailio,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/2900827243@kamailio
[Jul 3 06:28:39] NOTICE4125[C-0000000a]: chan_sip.c:23990 handle_response_invite: Failed to authenticate on INVITE to '"S1907031828398600051" <sip::5070>;tag=as2b71ef8a'
-- SIP/kamailio-00000000 is circuit-busy
Everyone is busy/congested at this time (1:0/1/0)
-- Executing [99992900827243@default:2] Hangup("Local/99992900827243@default-00000000;2", "") in new stack
Spawn extension (default, 99992900827243, 2) exited non-zero on 'Local/99992900827243@default-00000000;2'
-- Executing [h@default:1] AGI") in new stack
-- <Local/99992900827243@default-00000000;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----21-----CONGESTION---------------SIP 407 Proxy Authentication Required) completed, returning 0 == Manager 'sendcron' logged off from 127.0.0.1

RE: FastAGI not working - Added by Demian Lizandro Biscocho 15 days ago

Can you post the content of your /etc/asterisk/sip-goautodial.conf? And also the output of "sip show peers" from the Asterisk CLI.

RE: FastAGI not working - Added by Steve Turner 14 days ago

[kamailio]
;encryption=yes ;uncomment for TLS encryption
disallow=all
allow=opus
allow=ulaw
type=friend
dtmfmode=rfc2833
context=default
qualify=yes
nat=force_rport,comedia
host=dialin.coredialing.com ;change me to my FQDN
insecure=port,invite

dialin*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
kamailio 51.79.68.24 Yes Yes 5060 OK (1 ms)
1 sip peers [Monitored: 1 online, 0 offline Unmonitored: 0 online, 0 offline]

RE: FastAGI not working - Added by Steve Turner 14 days ago

Steve Turner wrote:

[kamailio]
;encryption=yes ;uncomment for TLS encryption
disallow=all
allow=opus
allow=ulaw
type=friend
dtmfmode=rfc2833
context=default
qualify=yes
nat=force_rport,comedia
host=dialin.coredialing.com ;change me to my FQDN
insecure=port,invite

dialin*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
kamailio 51.79.68.24 Yes Yes 5060 OK (1 ms)
1 sip peers [Monitored: 1 online, 0 offline Unmonitored: 0 online, 0 offline]

and this is Kamailio:
Jul 05 14:51:34 dialin.coredialing.com /usr/sbin/kamailio1923: ERROR: <core> [core/parser/msg_parser.c:671]: parse_msg(): ERROR: parse_msg: message=<PING>
Jul 05 14:51:34 dialin.coredialing.com /usr/sbin/kamailio1923: ERROR: <core> [core/parser/msg_parser.c:330]: parse_headers(): bad header field [(null)]
Jul 05 14:52:34 dialin.coredialing.com /usr/sbin/kamailio1920: INFO: <core> [core/parser/parse_fline.c:87]: parse_first_line(): ERROR: parse_first_line: message too short: 4
Jul 05 14:52:34 dialin.coredialing.com /usr/sbin/kamailio1920: ERROR: <core> [core/parser/parse_fline.c:257]: parse_first_line(): parse_first_line: bad message (offset: 0)
Jul 05 14:52:34 dialin.coredialing.com /usr/sbin/kamailio1920: ERROR: <core> [core/parser/msg_parser.c:671]: parse_msg(): ERROR: parse_msg: message=<PING>
Jul 05 14:52:34 dialin.coredialing.com /usr/sbin/kamailio1920: ERROR: <core> [core/parser/msg_parser.c:330]: parse_headers(): bad header field [(null)]
Jul 05 14:53:35 dialin.coredialing.com /usr/sbin/kamailio1921: INFO: <core> [core/parser/parse_fline.c:87]: parse_first_line(): ERROR: parse_first_line: message too short: 4
Jul 05 14:53:35 dialin.coredialing.com /usr/sbin/kamailio1921: ERROR: <core> [core/parser/parse_fline.c:257]: parse_first_line(): parse_first_line: bad message (offset: 0)
Jul 05 14:53:35 dialin.coredialing.com /usr/sbin/kamailio1921: ERROR: <core> [core/parser/msg_parser.c:671]: parse_msg(): ERROR: parse_msg: message=<PING>
Jul 05 14:53:35 dialin.coredialing.com /usr/sbin/kamailio1921: ERROR: <core> [core/parser/msg_parser.c:330]: parse_headers(): bad header field [(null)]

RE: FastAGI not working - Added by Steve Turner 14 days ago

ok, i added the domain name in the /etc/hosts in line with localhost and now phone registers and can make calls. however, when logging in the phone do not hear the recorded message as normal.

127.0.0.1 localhost dialin.coredialing.com

now Kamailio registers to asterisk as 127.0.0.1 and not the server IP

Name/username Host Dyn Forcerport Comedia ACL Port Status Description
CommPeak 104.196.193.91 Yes Yes 5060 OK (34 ms)
kamailio 127.0.0.1 Yes Yes 5060 OK (8 ms)

RE: FastAGI not working - Added by Demian Lizandro Biscocho 12 days ago

Can you check if listener.pl is running? If not, remove it's PID file first in /tmp and run it.

RE: FastAGI not working - Added by Steve Turner 11 days ago

seems to be running, i can not find the exact perl script location. I have the error log file of 30mb. /tmp/listener.err

reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect

/tmp/listener.pid only says 2065

RE: FastAGI not working - Added by Steve Turner 11 days ago

Steve Turner wrote:

seems to be running, i can not find the exact perl script location. I have the error log file of 30mb. /tmp/listener.err

reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect
reconnect

/tmp/listener.pid only says 2065

deleted the PID file, restarted listener.pl, cleared error log file. after restart PID changed to 4457 and the error log again says RECONNECT

RE: FastAGI not working - Added by Wittie Manansala 11 days ago

Hi,

In your /etc/hosts try to comment:

From:
127.0.0.1 localhost dialin.coredialing.com

To
#127.0.0.1 localhost dialin.coredialing.com

And reload your asterisk.

Thanks

    (1-22/22)
    Go to top