Project

General

Profile

Issue in Agent login Screen

Added by suganthan kumar 7 months ago

Dear Team,

I can't login to the dialer in agent login page.when i choose the campaign it was loading in goautodial logo.But nothing is happen.Kindly help me to solve ASAP.

Thanks in Advance.


Replies (18)

RE: Issue in Agent login Screen - Added by Levy Ryan Nolasco 7 months ago

Hi,

Please post the httpd and ssl error log. Try the following commands to get more information on your issue.

tail /var/log/httpd/ssl_error_log -f
tail /var/log/httpd/error_log -f

RE: Issue in Agent login Screen - Added by suganthan kumar 7 months ago

Kindly find the logs...

[root@vaglxc01 asterisk]# tail /var/log/httpd/ssl_error_log -f
[Thu Oct 18 18:22:55.664960 2018] [ssl:warn] [pid 994] AH01909: RSA certificate configured for vaglxc01.goautodial.com:443 does NOT include an ID which matches the server name
[Thu Oct 18 18:26:29.560728 2018] [proxy_fcgi:error] [pid 1636] [client 192.168.1.5:56977] AH01071: Got error 'Primary script unknown\n', referer: https://192.168.1.10/agent.php
[Thu Oct 18 18:33:51.959706 2018] [proxy_fcgi:error] [pid 2131] [client 192.168.1.5:57672] AH01068: Got bogus version 114
[Thu Oct 18 19:23:56.697022 2018] [proxy_fcgi:error] [pid 13499] [client 192.168.1.5:65108] AH01071: Got error 'Primary script unknown\n', referer: https://192.168.1.10/agent.php
[Thu Oct 18 19:26:44.672042 2018] [proxy_fcgi:error] [pid 13576] [client 192.168.1.5:65373] AH01071: Got error 'Primary script unknown\n', referer: https://192.168.1.10/agent.php
[Thu Oct 18 19:26:50.638922 2018] [proxy_fcgi:error] [pid 13576] [client 192.168.1.5:65373] AH01068: Got bogus version 114
[Thu Oct 18 19:27:40.425049 2018] [proxy_fcgi:error] [pid 13420] [client 192.168.1.5:65393] AH01068: Got bogus version 114
[Thu Oct 18 19:34:17.242697 2018] [proxy_fcgi:error] [pid 14365] [client 192.168.1.5:50047] AH01071: Got error 'Primary script unknown\n', referer: https://192.168.1.10/agent.php
[Thu Oct 18 19:36:49.892569 2018] [proxy_fcgi:error] [pid 14371] [client 192.168.1.5:50392] AH01071: Got error 'Primary script unknown\n', referer: https://192.168.1.10/agent.php
[Thu Oct 18 19:37:16.834953 2018] [proxy_fcgi:error] [pid 14371] [client 192.168.1.5:50450] AH01071: Got error 'Primary script unknown\n', referer: https://192.168.1.10/agent.php

[root@vaglxc01 asterisk]# tail /var/log/httpd/error_log f
[Thu Oct 18 18:22:55.662411 2018] [alias:warn] [pid 994] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 18 will probably never match because it overlaps an earlier Alias.
[Thu Oct 18 18:22:55.662422 2018] [alias:warn] [pid 994] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 19 will probably never match because it overlaps an earlier Alias.
[Thu Oct 18 18:22:55.662426 2018] [alias:warn] [pid 994] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 20 will probably never match because it overlaps an earlier Alias.
[Thu Oct 18 18:22:55.662430 2018] [alias:warn] [pid 994] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 21 will probably never match because it overlaps an earlier Alias.
[Thu Oct 18 18:22:55.662434 2018] [alias:warn] [pid 994] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 22 will probably never match because it overlaps an earlier Alias.
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using vaglxc01.goautodial.com. Set the 'ServerName' directive globally to suppress this message
[Thu Oct 18 18:22:55.663063 2018] [auth_digest:notice] [pid 994] AH01757: generating secret for digest authentication ...
[Thu Oct 18 18:22:55.663975 2018] [lbmethod_heartbeat:notice] [pid 994] AH02282: No slotmem from mod_heartmonitor
[Thu Oct 18 18:22:56.228377 2018] [mpm_prefork:notice] [pid 994] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips mod_fcgid/2.3.9 PHP/7.0.31 configured -
resuming normal operations
[Thu Oct 18 18:22:56.228427 2018] [core:notice] [pid 994] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

RE: Issue in Agent login Screen - Added by suganthan kumar 7 months ago

Yes i have done all the steps mentioned in that post.

RE: Issue in Agent login Screen - Added by Levy Ryan Nolasco 7 months ago

Hi,

Did you use our ISO or you did a scratch install?

RE: Issue in Agent login Screen - Added by suganthan kumar 7 months ago

ISO file that is downloaded from Goautodial site only.

RE: Issue in Agent login Screen - Added by Levy Ryan Nolasco 7 months ago

Can you post the output of cat /var/www/html/php/goCRMAPISettings.php

RE: Issue in Agent login Screen - Added by suganthan kumar 7 months ago

Kindly find...

[root@vaglxc01 ~]# cat /var/www/html/php/goCRMAPISettings.php
define ('gourl', 'https://192.168.1.10/goAPIv2');
define ('goUser', 'goAPI');
define ('responsetype', 'json');

?>

RE: Issue in Agent login Screen - Added by Levy Ryan Nolasco 7 months ago

How about your GOWebRTC Dialer Settings

RE: Issue in Agent login Screen - Added by suganthan kumar 7 months ago

Kindly find the WebRTC screenshot.

RE: Issue in Agent login Screen - Added by Jackie Alfonso 7 months ago

Hi,

Please try to check systemctl status kamailio if its not active kindly run systemctl restart kamailio once its activated please run some test again.

org.png (19.4 KB) org.png

RE: Issue in Agent login Screen - Added by IT Dept 7 months ago

Has anyone here been able to successfully make this work on AWS EC2?

RE: Issue in Agent login Screen - Added by suganthan kumar 7 months ago

Jackie Alfonso wrote:

Hi,

Please try to check systemctl status kamailio if its not active kindly run systemctl restart kamailio once its activated please run some test again.

Hi,

i cant start kamailio service.When i try to start that service it shows failed.

RE: Issue in Agent login Screen - Added by Demian Lizandro Biscocho 7 months ago

IT Dept wrote:

Has anyone here been able to successfully make this work on AWS EC2?

Yes. We have a few installs of v4 on AWS EC2.

RE: Issue in Agent login Screen - Added by RACHID EL HIMANI 7 months ago

bonsoir je besoin une aide svp j'ai un probable sur login to dialer, j'ai déjà configurer la manuel ip et quand j'ai Click sur login to dialer après j'ai choisir la campagne et ca affiche :
Logging in to your phone. Please wait...

et j'ai un problème d'activation de kamailio

voir Screenshots Merci avance

login to dialer.png (26 KB) login to dialer.png error login to dialer
error kamailio.png (29.7 KB) error kamailio.png activation kamailio

RE: Issue in Agent login Screen - Added by Levy Ryan Nolasco 7 months ago

Hi,

Please check your kamailio settings. This link might help you

https://goautodial.org/projects/goautodialce/wiki/Version_4_How_To_Install_Goautodial_From_Scratch_using_CentOS_7X

Important! Change 127.0.0.1 to your public IP address and vaglxc01.goautodial.com to your FQDN
#!substdef "!MY_IP_ADDR!127.0.0.1!g"
#!substdef "!MY_DOMAIN!vaglxc01.goautodial.com!g"
Important! Change 127.0.0.1 to your public IP address and vaglxc01.goautodial.com to your FQDN

systemctl enable kamailio
systemctl restart kamailio

    (1-18/18)
    Go to top