Project

General

Profile

In order to use GOautodial, it is necessary to have kernel-3.10.0-862.11.6.el7.x86_64 installed. Without it, GOautodial will not function properly.

Added by beshoo beshoo 5 months ago

Hello everyone,

I have spent nearly five days attempting to install GOautodial from scratch, following the provided documentation.
I tried installing it on Docker, a dedicated server, and even a new VPS with Centos7.

However, I faced a recurring problem with "RTPEngine" which prevented me from installing it correctly and caused issues each time I attempted to do so.

yum install ngcp-rtpengine-kernel ngcp-rtpengine-dkms dkms kernel-devel

And you can not Recompile the kernel module:

cd /usr/src/ngcp-rtpengine-6.4.0.0-1.el7/

[root@af2d96519b53 ngcp-rtpengine-6.4.0.0-1.el7]# make
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
make -C /lib/modules/3.10.0-962.3.2.lve1.5.82.el7.x86_64/build M=/usr/src/ngcp-rtpengine-6.4.0.0-1.el7 O=/lib/modules/3.10.0-962.3.2.lve1.5.82.el7.x86_64/build modules
make: *** /lib/modules/3.10.0-962.3.2.lve1.5.82.el7.x86_64/build: No such file or directory.  Stop.
make: *** [modules] Error 2


systemctl enable ngcp-rtpengine
ngcp-rtpengine.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig ngcp-rtpengine on

[root@af2d96519b53 ngcp-rtpengine-6.4.0.0-1.el7]# systemctl status ngcp-rtpengine ngcp-rtpengine.service - LSB: NGCP rtpengine Loaded: loaded (/etc/rc.d/init.d/ngcp-rtpengine; bad; vendor preset: disabled) Active: failed (Result: exit-code) since Thu 2023-11-30 01:43:04 UTC; 6min ago Docs: man:systemd-sysv-generator(8) Nov 30 01:43:04 af2d96519b53 systemd[1]: Starting LSB: NGCP rtpengine... Nov 30 01:43:04 af2d96519b53 ngcp-rtpengine[10596]: /etc/rc.d/init.d/ngcp-rtpengine: line 20: /etc/rc.d/init.d/functions: No such file or directory Nov 30 01:43:04 af2d96519b53 ngcp-rtpengine[10596]: Starting rtpengine: /etc/rc.d/init.d/ngcp-rtpengine: line 189: daemon: command not found Nov 30 01:43:04 af2d96519b53 systemd[1]: ngcp-rtpengine.service: control process exited, code=exited status=127 Nov 30 01:43:04 af2d96519b53 systemd[1]: Failed to start LSB: NGCP rtpengine. Nov 30 01:43:04 af2d96519b53 systemd[1]: Unit ngcp-rtpengine.service entered failed state. Nov 30 01:43:04 af2d96519b53 systemd[1]: ngcp-rtpengine.service failed.

After conducting several tests, I decided to download the Goautodile ISO to check the kernel they used, which was kernel-3.10.0-862.11.6.el7.x86_64. However, changing the server to an older kernel is not a viable option due to the security risks involved.

Could you kindly advise on how to install RTPEngine on a new kernel server, such as 3.10.0-962.3.2.lve1.5.82.el7.x86_64 ?


Replies (5)

RE: In order to use GOautodial, it is necessary to have kernel-3.10.0-862.11.6.el7.x86_64 installed. Without it, GOautodial will not function properly. - Added by Demian Biscocho 4 months ago

It looks like you are running GOautodial on a virtual machine or container. CentOS 7 and GOautodial repositories do not have lowlatency kernel packages.

You need to install the header (or development files for DEB based) of the running kernel.

RE: In order to use GOautodial, it is necessary to have kernel-3.10.0-862.11.6.el7.x86_64 installed. Without it, GOautodial will not function properly. - Added by beshoo beshoo 4 months ago

Demian Biscocho wrote in RE: In order to use GOautodial, it is necessary to have k...:

It looks like you are running GOautodial on a virtual machine or container. CentOS 7 and GOautodial repositories do not have lowlatency kernel packages.

You need to install the header (or development files for DEB based) of the running kernel.

I already did that...
but it is not working...

RE: In order to use GOautodial, it is necessary to have kernel-3.10.0-862.11.6.el7.x86_64 installed. Without it, GOautodial will not function properly. - Added by Demian Biscocho 4 months ago

Your kernel headers for kernel 4.15.0-15-lowlatency cannot be found.. as per your screenshot. So you haven't really installed the necessary kernel headers for your running kernel.

RE: In order to use GOautodial, it is necessary to have kernel-3.10.0-862.11.6.el7.x86_64 installed. Without it, GOautodial will not function properly. - Added by beshoo beshoo 4 months ago

Demian Biscocho wrote in RE: In order to use GOautodial, it is necessary to have k...:

Your kernel headers for kernel 4.15.0-15-lowlatency cannot be found.. as per your screenshot. So you haven't really installed the necessary kernel headers for your running kernel.

I moved to KVM VPS ,a nd install the ISO, and this sort out this problem.

    (1-5/5)
    Go to top