Project

General

Profile

Agent login to dialer issue

Added by James King over 1 year ago

Hi all ,

I have been trying to run GOautodial V.4 but facing only one issue

I installed from ISO image and all configuration went good,

Kamailio is ok
RTPengine OK
FQDN Ok
SQL Ok
SSL certificate Ok

When i try to login as agent, i have to press login to dialer 2 times , then i hear myself without establishing a call .
Then i have to dial any number to close this session , then when i press dial again nothing happens .

I have been tracing this issue for a long time , the only thing i noticed is this error at the kamailio after agent login and pressing login to dialer

Nov 21 02:35:46 techurity2.ddns.net /usr/sbin/kamailio1871: NOTICE: acc [acc.c:295]: acc_log_request(): ACC: transaction answered: timestamp=1668990946;method=INVITE;from_tag=as703b93be;to_tag=849leeqhe2;call_id=:5070;code=200;reason=OK;src_user=5164536886;src_domain=127.0.0.1;src_ip=127.0.0.1;dst_ouser=1633365789;dst_user=al4bnjlh;dst_domain=gpet5a91c3va.invalid

when agent logout or close the test call. this i see at kamailio log
Nov 21 02:41:15 myserver /usr/sbin/kamailio1871: NOTICE: acc [acc.c:295]: acc_log_request(): ACC: transaction answered: timestamp=1668991275;method=BYE;from_tag=as367d2483;to_tag=hfkvdsg1gi;call_id=:5070;code=200;reason=OK;src_user=5164536886;src_domain=127.0.0.1;src_ip=127.0.0.1;dst_ouser=1633365789;dst_user=al4bnjlh;dst_domain=gpet5a91c3va.invalid

on the browser console i see this at the log, i believe its related to the issue

VM1048:1 Uncaught SyntaxError: Unexpected token ';'
at eval (<anonymous>)
at Function.globalEval (jquery.min.js:2:2538)
at String.<anonymous> (GOagentJS.php:1693:43)
at Function.each (jquery.min.js:2:2936)
at Object.<anonymous> (GOagentJS.php:1573:27)
at j (jquery.min.js:2:26911)
at Object.fireWith [as resolveWith] (jquery.min.js:2:27724)
at x (jquery.min.js:4:11065)
at XMLHttpRequest.<anonymous> (jquery.min.js:4:14577)
globalEval jquery.min.js:2
(anonymous)
GOagentJS.php:1693
each jquery.min.js:2
(anonymous)
GOagentJS.php:1573
j jquery.min.js:2
fireWith
jquery.min.js:2
x jquery.min.js:4
(anonymous)
jquery.min.js:4
load (async)
send jquery.min.js:4
ajax
jquery.min.js:4
(anonymous) GOagentJS.php:1545
setInterval (async)
(anonymous)
GOagentJS.php:1530
dispatch jquery.min.js:3
r.handle
jquery.min.js:3
VM1235:1 Uncaught SyntaxError: Unexpected token ';'
at eval (<anonymous>)
at Function.globalEval (jquery.min.js:2:2538)
at String.<anonymous> (GOagentJS.php:1693:43)
at Function.each (jquery.min.js:2:2936)
at Object.<anonymous> (GOagentJS.php:1573:27)
at j (jquery.min.js:2:26911)
at Object.fireWith [as resolveWith] (jquery.min.js:2:27724)
at x (jquery.min.js:4:11065)
at XMLHttpRequest.<anonymous> (jquery.min.js:4:14577)

Please i need urgent help about my issue.


Replies (6)

RE: Agent login to dialer issue - Added by Wittie Manansala over 1 year ago

Hi,

Please update to latest version by following the steps posted here: https://goautodial.org/projects/goautodialce/wiki/HOWTO_Update_latest_version_via_Github

Try also below steps:

1. nano /etc/kamailio/tls.cfg
2. look for method = TLSv1 and change it to method = TLSv1+
3. systemctl restart kamailio

Thanks

RE: Agent login to dialer issue - Added by James King over 1 year ago

Hello,

Thanks for your quick reply @ Wittie Manansala

I already followed all the steps couple of installations i always face the same issue...

Is it normally that <sip show peers> shows Kamailio with IP 127.0.0.1 or it should be another one.

((((If there is any config or log you want me to post please feel free to ask..))))

Your support is highly appreciated...

RE: Agent login to dialer issue - Added by James King over 1 year ago

Hi, Wittie

Can you please check your email , or provide me with your active email.

Thanks
BR

RE: Agent login to dialer issue - Added by Wittie Manansala over 1 year ago

Hi,

For professional support please email us at .

Thank you

RE: Agent login to dialer issue - Added by Charlie Jone about 1 year ago

Wittie Manansala wrote in RE: Agent login to dialer issue:

Hi,

Please update to latest version by following the steps posted here: https://goautodial.org/projects/goautodialce/wiki/HOWTO_Update_latest_version_via_Github
Try also below steps:

1. nano /etc/kamailio/tls.cfg
2. look for method = TLSv1 and change it to method = TLSv1+
3. systemctl restart kamailio

Thanks

It totally works. Before, I try to replicate the issue while monitoring the system closely. Take note of any specific steps or actions that consistently trigger the problem but cannot identify the root cause.

RE: Agent login to dialer issue - Added by Wittie Manansala 7 months ago

Are you able to fix the issue? If not

Please provide the following information:.

1. screenshot of asterisk CLI logs when logging in.
2. screenshot nano /etc/kamailio/tls.cfg
3. systemctl status kamailio
4. systemctl status rtpengine

Thank you

    (1-6/6)
    Go to top