Project

General

Profile

Issue with inbound call from PSTN - No Sounds, No live call, call drops.

Added by Leopoldo Martinez about 2 months ago

Hi, i finally could route inbound call to an agent, i was making all my test from my softphone to my goautodial, and all works fine (still working fine), but when i call from a real phone (PSTN Phone) the call drops, i can't hear any IVR, sound or nothing, just drop the call. please any help, this is really urgent.


Replies (9)

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Leopoldo Martinez about 2 months ago

Hey, i could solve the problem above, was something with codecs, all fine now. But the life is not so easy and perfect, now I'm facing a new problem, the call from PSTN is ok, the can hear the IVR, but the can talk with an agent because the call drops inmediately, the error that i can see in asterisk cli is this one.

ERROR12044[C-000098fa]: member.c:404 member_exec: unable to create member

HERE IS THE COMPLETE TRACE OF ASTERISK CLI

Using SIP RTP CoS mark 5
Executing [910883259@trunkinbound:1] AGI in new stack
Launched AGI Script /usr/share/asterisk/agi-bin/agi-DID_route.agi
<SIP/SOLIVESA-00003f17>AGI Script agi-DID_route.agi completed, returning 0
Executing [99909*78***DID@default:1] Answer("SIP/SOLIVESA-00003f17", "") in new stack
Executing [99909*78***DID@default:2] AGI in new stack
Launched AGI Script /usr/share/asterisk/agi-bin/agi-VDAD_ALL_inbound.agi
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
Manager 'sendcron' logged on from 127.0.0.1
Called 127*000*000*001*78600089@default
Executing [127*000*000*001*78600089@default:1] Goto("Local/127*000*000*001*78600089@default-00005bc6;2", "default,78600089,1") in new stack
Goto (default,78600089,1)
Executing [78600089@default:1] Konference("Local/127*000*000*001*78600089@default-00005bc6;2", "8600089,qR") in new stack
Local/127*000*000*001*78600089@default-00005bc6;1 answered
Executing [83047777777777@vicidial-auto:1] Answer("Local/127*000*000*001*78600089@default-00005bc6;1", "") in new stack
Executing [83047777777777@vicidial-auto:2] Playback("Local/127*000*000*001*78600089@default-00005bc6;1", "ding") in new stack
<Local/127*000*000*001*78600089@default-00005bc6;1> Playing 'ding.gsm' (language 'en')
Manager 'sendcron' logged off from 127.0.0.1
Executing [83047777777777@vicidial-auto:3] Hangup("Local/127*000*000*001*78600089@default-00005bc6;1", "") in new stack
Spawn extension (vicidial-auto, 83047777777777, 3) exited non-zero on 'Local/127*000*000*001*78600089@default-00005bc6;1'
[Jun 4 20:56:45] WARNING9521[C-000098eb]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
Executing [h@vicidial-auto:1] AGI") in new stack
<Local/127*000*000*001*78600089@default-00005bc6;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------) completed, returning 0
[Jun 4 20:56:45] WARNING9522[C-000098ea]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
Executing [h@default:1] AGI") in new stack
<Local/127*000*000*001*78600089@default-00005bc6;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------) completed, returning 0
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f17>AGI Script agi-VDAD_ALL_inbound.agi completed, returning 0
Executing [127*000*000*001*8600089@default:1] Goto("SIP/SOLIVESA-00003f17", "default,8600089,1") in new stack
Goto (default,8600089,1)
Executing [8600089@default:1] Konference("SIP/SOLIVESA-00003f17", "8600089,R") in new stack
[Jun 4 20:56:46] ERROR9514[C-000098e9]: member.c:404 member_exec: unable to create member
Spawn extension (default, 8600089, 1) exited non-zero on 'SIP/SOLIVESA-00003f17'
[Jun 4 20:56:46] WARNING9514[C-000098e9]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
Executing [h@default:1] AGI") in new stack
<SIP/SOLIVESA-00003f17>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------------) completed, returning 0
Manager 'sendcron' logged on from 127.0.0.1
Called 58600089@default
Executing [58600089@default:1] Konference("Local/58600089@default-00005bc7;2", "8600089,qLR") in new stack
Local/58600089@default-00005bc7;1 answered
Executing [8309@default:1] Answer("Local/58600089@default-00005bc7;1", "") in new stack
Executing [8309@default:2] Monitor("Local/58600089@default-00005bc7;1", "wav,20210604-155645_617899753_16514963_PILOT1") in new stack
Manager 'sendcron' logged off from 127.0.0.1
Executing [8309@default:3] Wait("Local/58600089@default-00005bc7;1", "3600") in new stack
Using SIP RTP CoS mark 5
Executing [910883259@trunkinbound:1] AGI in new stack
Launched AGI Script /usr/share/asterisk/agi-bin/agi-DID_route.agi
<SIP/SOLIVESA-00003f18>AGI Script agi-DID_route.agi completed, returning 0
Executing [99909*78***DID@default:1] Answer("SIP/SOLIVESA-00003f18", "") in new stack
Executing [99909*78***DID@default:2] AGI in new stack
Launched AGI Script /usr/share/asterisk/agi-bin/agi-VDAD_ALL_inbound.agi
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18> Playing 'sip-silence.gsm' (escape_digits=) (sample_offset 0) (language 'en')
<SIP/SOLIVESA-00003f18>AGI Script agi-VDAD_ALL_inbound.agi completed, returning 0
Executing [8307@default:1] Answer("SIP/SOLIVESA-00003f18", "") in new stack
Executing [8307@default:2] Playback("SIP/SOLIVESA-00003f18", "vm-goodbye") in new stack
<SIP/SOLIVESA-00003f18> Playing 'vm-goodbye.gsm' (language 'en')
Manager 'sendcron' logged on from 127.0.0.1
Manager 'sendcron' from 127.0.0.1, hanging up channel: Local/58600089@default-00005bc7;2
[Jun 4 20:56:53] WARNING9534[C-000098ec]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
Executing [h@default:1] AGI") in new stack
Manager 'sendcron' logged off from 127.0.0.1
<Local/58600089@default-00005bc7;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------------) completed, returning 0
Spawn extension (default, 8309, 3) exited non-zero on 'Local/58600089@default-00005bc7;1'
[Jun 4 20:56:53] WARNING9533[C-000098ed]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
Executing [h@default:1] AGI") in new stack
<Local/58600089@default-00005bc7;1>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------------) completed, returning 0
[Jun 4 20:56:57] WARNING9535[C-000098ee]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
Executing [h@default:1] AGI") in new stack

Any one can help me? give me and advise or somethin, I would apreciate it.
Thanks.

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Wittie Manansala about 2 months ago

Hi,

Please provide the following:

1. DID Settings screenshot
2. Ingroup Settings screenshot
3. Carrier Settings for your INBOUND
4. Asterisk CLI log when calling your inbound screenshot

Thanks

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Demian Lizandro Biscocho about 2 months ago

This is a codec issue. Have you tried using G711/Ulaw?

<quote>
Executing [8600089@default:1] Konference("SIP/SOLIVESA-00003f17", "8600089,R") in new stack
[Jun 4 20:56:46] ERROR9514[C-000098e9]: member.c:404 member_exec: unable to create member
</quote>

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Leopoldo Martinez about 2 months ago

Demian Lizandro Biscocho wrote in RE: Issue with inbound call from PSTN - No Sounds, No liv...:

This is a codec issue. Have you tried using G711/Ulaw?

<quote>
Executing [8600089@default:1] Konference("SIP/SOLIVESA-00003f17", "8600089,R") in new stack
[Jun 4 20:56:46] ERROR9514[C-000098e9]: member.c:404 member_exec: unable to create member
</quote>

Yes, as you see in one of the pics that our friend Wittie Manansala asked, you can see it

allow=ulaw

What other thing can i try?

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Leopoldo Martinez about 1 month ago

Wittie Manansala wrote in RE: Issue with inbound call from PSTN - No Sounds, No liv...:

Hi,

Please provide the following:

1. DID Settings screenshot
2. Ingroup Settings screenshot
3. Carrier Settings for your INBOUND
4. Asterisk CLI log when calling your inbound screenshot

Thanks

HI, have you check it out?

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Leopoldo Martinez about 1 month ago

Demian Lizandro Biscocho wrote in RE: Issue with inbound call from PSTN - No Sounds, No liv...:

This is a codec issue. Have you tried using G711/Ulaw?

<quote>
Executing [8600089@default:1] Konference("SIP/SOLIVESA-00003f17", "8600089,R") in new stack
[Jun 4 20:56:46] ERROR9514[C-000098e9]: member.c:404 member_exec: unable to create member
</quote>

Hi, I'm still facing the same error

I'm using
G711/Ulaw = Doesn't work
G711/Alaw = Doesn't work
G729 = Doesn't work
GSM = Doesn't work

please i need to solve this.

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Leopoldo Martinez about 1 month ago

Well, I have managed to get some calls in, but not others. I am going to leave samples of the call that I manage to enter against the other 2 that do not. I'm pretty sure one of them is due to the fact that the number I called from is in private mode, but the other, I have no idea why the call won't accept it.

here is the acepted call.

This one is a non acepted call.

And this is the anonymous or private number

I have installed g729, and i hace active GSM, ALAW, ULAW, G729. I triyed activating and deactivation some codec, the result is allways de same.

RE: Issue with inbound call from PSTN - No Sounds, No live call, call drops. - Added by Wittie Manansala 29 days ago

Hi,

Have you tried to coordinate the issue to your VOIP Provider? If Yes, what is there advise/recommendation?

Try also to route your inbound call in musiconhold or specific extension and check if calls goes through.

Thanks

    (1-9/9)
    Go to top