Project

General

Profile

Auto-dialing does not work.

Added by Anatoli Borodin 7 months ago

Auto-dialing does not work. Don't know what to do anymore? Where to look for the reason? I can make a call in the manual.


Replies (4)

RE: Auto-dialing does not work. - Added by Wittie Manansala 7 months ago

Hi,

Please provide the following:

1. Campaign Basic & Advance Settings screenshot.
2. Complete Carrier Settings
3. Complete Asterisk CLI (from the agent logged-in to presses Resume button)
4. VOIP Provider Requirements, like if they required dial prefix, ANI or Callerid and codec.

Thanks

RE: Auto-dialing does not work. - Added by Arman Grigo 4 months ago

Anatoli Borodin wrote:

Auto-dialing does not work. Don't know what to do anymore? Where to look for the reason? I can make a call in the manual.

You were able to solve the autodial problem?

RE: Auto-dialing does not work. - Added by Leopoldo Martinez 3 months ago

Wittie Manansala wrote in RE: Auto-dialing does not work.:

Hi,

Please provide the following:

1. Campaign Basic & Advance Settings screenshot.
2. Complete Carrier Settings
3. Complete Asterisk CLI (from the agent logged-in to presses Resume button)
4. VOIP Provider Requirements, like if they required dial prefix, ANI or Callerid and codec.

Thanks

Screenshots

Carrier Settings

register => XXXXXXXXX::5060/XXXXXXX

[Imperia]
disallow=all
type=friend
dtmfmode=rfc2833
context=trunkinbound
qualify=yes
insecure=invite,port
nat=force_rport,comedia
host=139.XXX.162.XXX
username=XXXXXXXXX
secret=XXXXXXXXXX
allow=g729

exten => _1234567890.,1,AGI
exten => _1234567890.,2,Dial(SIP/${EXTEN:10}@Imperia,,tTo)
exten => _1234567890.,3,Hangup

Asterisk CLI
Connected to Asterisk 13.17.2-vici currently running on imperia (pid = 1693)
Manager 'sendcron' logged on from 127.0.0.1
-- Called 99992618224291@default
-- Executing [99992618224291@default:1] Dial("Local/99992618224291@default-00000008;2", "SIP/2618224291@kamailio,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/2618224291@kamailio
-- SIP/kamailio-00000004 is ringing
-- Local/99992618224291@default-00000008;1 is ringing
> 0x7fc1b00045d0 -- Strict RTP learning after remote address set to: 45.77.102.241:30086
-- SIP/kamailio-00000004 answered Local/99992618224291@default-00000008;2
-- Local/99992618224291@default-00000008;1 answered
-- Executing [8600051@default:1] Konference("Local/99992618224291@default-00000008;1", "8600051,R") in new stack == Manager 'sendcron' logged off from 127.0.0.1
-- Channel SIP/kamailio-00000004 joined 'simple_bridge' basic-bridge <0eefe522-4c8d-4f21-97bd-07b25919ec9b>
-- Channel Local/99992618224291@default-00000008;2 joined 'simple_bridge' basic-bridge <0eefe522-4c8d-4f21-97bd-07b25919ec9b>
> 0x7fc1b00045d0 -- Strict RTP switching to RTP target address 45.77.102.241:30086 as source
> 0x7fc1b00045d0 -- Strict RTP learning complete - Locking on source address 45.77.102.241:30086
[Feb 8 21:01:39] WARNING16043[C-0000000f]: file.c:774 ast_openstream_full: File confbridge-join does not exist in any format

VOIP Provider Requirements

Protocolo: SIP 2.0
SIP Proxy: 139.xxx.162.xxx
Códec: G729/G711
Formato: E.164
Usuario: XXXXXX
Clave: XXXXXXXXXXXXXXXX

I have the same Problem. This Server used to made auto-dialing, but not any more... need help

RE: Auto-dialing does not work. - Added by Levy Ryan Nolasco 3 months ago

Hi,

Please set the minimum hopper level: 50 or more. Check the campaign hopper as well before you do autodial

    (1-4/4)
    Go to top