Project

General

Profile

yum update issue for Dahdi

Added by David Reedy about 1 month ago

Hello everyone,

I am trying to run the yum updates and Dahdi is coming up with an error.

file /usr/lib64/libtonezone.so.2.0.0 from install of dahdi-tools-libs-2.11.1-16.el7.x86_64 conflicts with file from package 
libtonezone-2.11.1-1.el7.centos.x86_64

This is preventing me from doing a complete update and i would like to stay current. Does anyone have any ideas how to fix this issue?


Replies (4)

RE: yum update issue for Dahdi - Added by Demian Lizandro Biscocho about 1 month ago

There's a package conflict with the EPEL repository. To solve this, you can safely uninstall libtonezone and replace it with the dahdi-tools-libs package.

# rpm -e --nodeps libtonezone

Then proceed with the yum update.

RE: yum update issue for Dahdi - Added by Demian Lizandro Biscocho about 1 month ago

Alternately, you can prevent dahdi-tools from being upgraded by appending the following to /etc/yum.conf:

exclude=dahdi-tools*

You can then proceed with the yum update without uninstalling libtonezone.

RE: yum update issue for Dahdi - Added by David Reedy about 1 month ago

Thank you Demian,

I went with option 1 as i like to say current with all packages. Is there a benefit to excluding dahdi-tools?

RE: yum update issue for Dahdi - Added by Demian Lizandro Biscocho about 1 month ago

Excluding dahdi-tools from the upgrade list just prevents the package conflict (of dahdi-tools-lib package from the EPEL repo) from libtonezone (package from GOautodial repo). Both actually provide the same libtonezone.so library file.

    (1-4/4)
    Go to top