Project

General

Profile

High System Load

Added by Rohit Mathur about 2 months ago

Hello Everyone,

Using all the useful information and help from everyone in this community, I have successfully installed GA4 with FQDN and SSL. Thanks for a wonderful support!

The only issue I am facing now is SYSTEM LOAD.

My server is in ideal state since few days and I am noticing, system load is fluctuating between 1% to 155%.

I tried these steps from :https://goautodial.org/boards/3/topics/16203?r=16713#message-16713

1. Edit: /var/www/html/php/dashboard/API_getRealtimeAgentsMonitoring.php
On line 30 change:

if (!empty($output->data)) {
to:

if (is_array($output->data) && !empty($output->data)) {
2. Edit: /var/www/html/php/dashboard/API_getAgentsMonitoringSummary.php
On line 39 change:

} else {
to:

} elseif(is_array($output->data)) {

Still there is not difference:

System is updated.
Its a dedicated server on Velia.net
Server config:

Intel Xeon E3-1230 v3
Cores: 4x 3.30 GHz (Single Quad Core)
RAM: 16 GB DDR3 ECC
HDDs: 2x 480 GB SSD

Please suggest if there is a fix for this. Also suggest how many agents do you think this config will be able to handle on Autodial 4.5 dial level and recording on. Codec ulaw will be used.


Replies (2)

RE: High System Load - Added by Wittie Manansala about 1 month ago

Hi,

Please provide below information for us to review

1. How many seats are you planning to run?
2. Inbound, outbound or blended calls?
3. Are you going to record all calls?
4. Are you using virtual machine?

Thanks

RE: High System Load - Added by Demian Lizandro Biscocho about 1 month ago

The system load average on the dashboard doesn't count the number of cores. For a 4 CPU core system, 400% is the fully utilized load average.

    (1-2/2)
    Go to top