Project

General

Profile

Problem With Kamailio adn Dialer -- Scratch Installation FQDN

Added by Vericar De Espiritu Santo about 2 years ago

First I will start by saying what methods I use and how I did each of the steps, also what type of server I have.

I have a VPS Server in GCP (Google Cloud Platform) the installation process I used was this one:

https://goautodial.org/boards/3/topics/16487

STOP AND DISABLE FIREWALL: DONE

systemctl disable firewalld
systemctl stop firewalld

DISABLE SELINUX: DONE, I USE NANO

vi /etc/selinux/config
SELINUX=disabled (Change to disabled)

UPDATE HOSTNAME: DONE I USE NANO

hostnamectl set-hostname xxxxxx.xxxxx.xxx
vi /etc/hosts
change domain name for actual server ip (xxx.xxx.xxx.xxx complete domain name subdomain only)

CHANGE SSH PORT: (remember this or you will be locked out) I DIDN'T THIS STEP

vi /etc/ssh/sshd_config
uncomment #Port and change to preferred new port number

UPDATE SYSTEM: DONE

yum install wget -y

cd /etc/yum.repos.d/
wget http://downloads2.goautodial.org/centos/7/goautodial.repo

yum update -y

reboot (use new port number if was changed)

INSTALL DEPENDENCIES: DONE

yum install -y epel-release
yum groupinstall "Development Tools" -y

wget https://rpm.mag-sol.com/Centos/7/x86_64/perl-Sys-RunAlone-0.12-1.el7.centos.noarch.rpm
rpm -i perl-Sys-RunAlone-0.12-1.el7.centos.noarch.rpm

yum install y MariaDB-server MariaDB-devel php70w-mysql php70w-mcrypt php70w-devel php70w-mbstring php70w-common php70w-xml php70w-pear php70w-cli php70w-imap php70w-fpm php70w-gd php70w>opcache php70w-pdo php70w-process php70w php70w-intl php70w-pear.noarch php70w-xmlrpc asterisk-mysql-13.17.2-vici.el7.centos.x86_64 asterisk-perl-0.08-2.go.x86_64 asterisk-voicemail-plain->13.17.2-vici.el7.centos.x86_64 asterisk-devel-13.17.2-vici.el7.centos.x86_64 asterisk-voicemail-13.17.2-vici.el7.centos.x86_64 asterisk-alsa-13.17.2-vici.el7.centos.x86_64 asterisk-sip->13.17.2-vici.el7.centos.x86_64 asterisk-13.17.2-vici.el7.centos.x86_64 asterisk-dahdi-13.17.2-vici.el7.centos.x86_64 asterisk-iax2-13.17.2-vici.el7.centos.x86_64 asterisk-mp3-13.17.2->vici.el7.centos.x86_64 kamailio-tls kamailio kamailio-mysql kamailio-ims kamailio-utils kamailio-websocket kamailio-json perl-Math-Round perl-File-Touch perl-Sys-RunAlone perl-Switch perl->Time-Local ngcp-rtpengine ngcp-rtpengine-kernel ngcp-rtpengine-dkms dkms dahdi-linux dahdi-linux-devel kernel-devel perl-DBD-mysql perl-Net-Telnet lame httpd mod_ssl screen crontabs mailx net->tools readline readline-devel ncurses ncurses-devel tk tk-devel htop perl-DBI perl-Digest-HMAC perl-YAML perl-ExtUtils-ParseXS perl-NetAddr-IP perl-Crypt-SSLeay perl-Curses perl-DBD-Pg perl->Module-ScanDeps perl-Text-CSV perl-HTML-Template perl-IO-Compress perl-Text-Glob perl-Jcode perl-Test-Script perl-Archive-Tar perl-Test-Base perl-OLE-Storage_Lite perl-Archive-Zip perl-Net->Server perl-Convert-ASN1 perl perl-Compress-Raw-Zlib perl-Digest-SHA1 perl-Data-Dumper perl-Error perl-ExtUtils-CBuilder perl-Test-Tester perl-Parse-RecDescent perl-Spiffy perl-IO-Zlib perl->Module-Build perl-HTML-Parser perl-Net-SSLeay perl-Proc-ProcessTable perl-TermReadKey perl-Term-ReadLine-Gnu perl-Digest-SHA perl-Tk perl-Net-SNMP perl-Test-NoWarnings perl-XML-Writer perl->Proc-PID-File perl-Compress-Raw-Bzip2 perl-libwww-perl perl-XML-Parser perl-File-Remove perl-Parse-CPAN-Meta perl-Set-Scalar perl-Probe-Perl perl-File-Which perl-Package-Constants perl-Module->Install perl-File-HomeDir perl-Spreadsheet-ParseExcel perl-Mail-Sendmail perl-Spreadsheet-XLSX perl-version perl-Crypt-DES perl-URI perl-Net-Daemon perl-IO-stringy perl-YAML-Tiny perl-HTML->Tagset perl-Socket6 perl-BSD-Resource perl-PlRPC perl-IPC-Run3 perl-Text-CSV_XS perl-Unicode-Map perl-Module-CoreList perl-Net-Telnet perl-PAR-Dist perl-Date-Manip perl-JSON perl-Proc-Daemon >perl-Spreadsheet-WriteExcel perl-rrdtool sox ntp iftop subversion glibc.i686 mod_fcgid

INSTALL CPAN and PERL SCRIPTS: (run twice or until all are installed with dependencies) DONE, I HAD TO RAN THIS 3 TIMES

cpan -i Tk String::CRC Tk::TableMatrix Net::Address::IP::Local Term::ReadLine::Gnu Spreadsheet::Read Net::Address::IPv4::Local RPM::Specfile Spreadsheet::XLSX Spreadsheet::ReadSXC

SHOULD HAVE THIS OUTPUT ON CONSOLE: I HAD THIS OUTPUT, WITH SOME DIFERENCES IN TE NUMBERS

CPAN: Module::CoreList loaded ok (v2.76_02) SAME OUTPUT
Tk is up to date (804.034). SAME OUTPUT
String::CRC is up to date (1). SAME OUTPUT
Tk::TableMatrix is up to date (1.23). SAME OUTPUT
Net::Address::IP::Local is up to date (0.1.2). SAME OUTPUT
Term::ReadLine::Gnu is up to date (1.36). SAME OUTPUT
Spreadsheet::Read is up to date (0.80). I GET 0.81
Net::Address::IPv4::Local is up to date (0.12). SAME OUTPUT
RPM::Specfile is up to date (1.51). SAME OUTPUT
Spreadsheet::XLSX is up to date (0.15). SAME OUTPUT
Spreadsheet::ReadSXC is up to date (0.20). I GET 0.24

ENABLE SERVICES ON START-UP AND START MYSQL: DONE

systemctl enable php-fpm
systemctl enable httpd
systemctl enable mariadb
systemctl enable kamailio
systemctl enable ngcp-rtpengine
systemctl start mariadb

INSTALL GOAUTODIAL: DONE

yum -y install goautodial-ce
cd /usr/src/goautodial
./install.sh

reboot (seems databases are not created until after reboot,on some instances a HARD REBOOT is required)

CONFIRM DATABASES CREATED: DONE

mysql
MariaDB [(none)]>show databases;

Should show 8 Databases
asterisk
goautodial
information_schema
kamailio
mysql
osticketdb
performance_schema
test
8 rows in set (0.00 sec) SAME OUTPUT

UPDATE GOAUTODIAL TABLE IN MYSQL: DONE

use goautodial;
ALTER TABLE go_campaigns ADD COLUMN manual_dial_min_digits INT DEFAULT '6';
ALTER TABLE users ADD COLUMN enable_webrtc tinyint(1) DEFAULT '1';
quit;

UPDATE GOAUTODIAL WITH GIT: DONE, HERE I CONFIGURED MY OWN ACCOUNT OF GITHUB

cd /var/www/html
git config --global user.email "MY EMAIL"
git config --global user.name "MY USER NAME"
git stash
git pull

cd /var/www/html/goAPIv2
git stash
git pull

CHANGE FILE OWNERSHIP: (GIT files are replaced with ROOT as owner and need to be changed to APACHE owner) DONE

chown apache.apache -R /var/www/html

UPDATE CRONTAB: DONE

crontab -e (be sure to add --HTTPS to end of 4th line of recording scripts)

1,4,7,10,13,16,19,22,25,28,31,34,37,40,43,46,49,52,55,58 * * * * /usr/share/astguiclient/AST_CRON_audio_2_compress.pl --MP3 --HTTPS

UPDATE IPs AND FQDN: DONE

Kamailio:
vi /etc/kamailio/kamailio.cfg
Around line 136:
#!substdef "!MY_IP_ADDR!10.10.100.164!g" (use your IP address) done
#!substdef "!MY_DOMAIN!xxxxx.xxxxx.xxx!g" (use your FQDN) MY FQDN IS go.callebisu.com

/* add local domain aliases /
alias="subdomain.domainname.com" *go.callebisu.com

alias="domainname.com" callebisu.com

RTPEngine:
vi /etc/rtpengine/rtpengine.conf
Around line 8:
a single interface:
interface = 10.10.100.164 (use your IP address) DONE

GOautodial web application
vi /var/www/html/php/goCRMAPISettings.php
Change IP address to your FQDN and then restart Kamailio and RTPEngine. DONE, I PUT go.callebisu.com

CHANGE KAMAILIO DOMAIN: DONE

vi /etc/asterisk/sip-goautodial.conf

[kamailio]
;encryption=yes ;uncomment for TLS encryption
disallow=all
allow=opus
allow=ulaw
type=friend
dtmfmode=rfc2833
context=default
qualify=yes
nat=force_rport,comedia
host=xxxxxxx.xxxxxxx.xxx ;change me to my FQDN DONE go.callebisu.com
insecure=port,invite

SET DOMAIN IN HTTP.CONF: (about line 95)

vi /etc/httpd/conf/httpd.conf
uncomment Servername and change to your FQDN (xxxx.xxxx.xxx:80) DONE, go.callebisu.com:80

UPDATE DEFAULT TIME ZONE: (about line 877)

vi /etc/php.ini
date.timezone = Asia/Manila (change to your timezone) DONE

RUN UPDATE IP SCRIPT:

/usr/share/astguiclient/ADMIN_update_server_ip.pl (should show old IP as 127.0.0.1) DONE

UPDATE SELF-SIGNED SSL CERT TO NEW DOMAIN: DONE

openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/pki/tls/private/localhost.key -out /etc/pki/tls/certs/localhost.crt

CREATE LINK FOR RECORDINGS: I JUMPED THIS STEP

If you have an issue with recordings a solution is to manually create an symbolic link in
the folder html named RECORDINGS poiting to the file where asterisk store the recordings
files.
cd /var/www/html
ln -s /var/spool/asterisk/monitorDONE/ RECORDINGS
If you get NOT AUTHORIZED errors you must change the chmod of all the folders in the
path /var/spool/asterisk/monitorDONE/MP3/.

REBOOT: (to be sure system survives reboot) DONE AND IT SURVIVED

reboot

CHECK THEIR STATUSES: DONE, AND START MY HEADACHE

systemctl status ngcp-rtpengine ACTIVE AND RUNNING, GREEN
systemctl status kamailio Active: failed, RED

HERE THE OUTPUT
kamailio.service - Kamailio (OpenSER) - the Open Source SIP Server
Loaded: loaded (/usr/lib/systemd/system/kamailio.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Wed 2020-01-15 19:38:41 UTC; 6h ago
Main PID: 1504 (code=exited, status=255)

Jan 15 19:38:41 voip-11 systemd1: kamailio.service: main process exited, code=exited, status=255/n/a
Jan 15 19:38:41 voip-11 systemd1: Unit kamailio.service entered failed state.
Jan 15 19:38:41 voip-11 systemd1: kamailio.service failed.
Jan 15 19:38:41 voip-11 systemd1: kamailio.service holdoff time over, scheduling restart.
Jan 15 19:38:41 voip-11 systemd1: Stopped Kamailio (OpenSER) - the Open Source SIP Server.
Jan 15 19:38:41 voip-11 systemd1: start request repeated too quickly for kamailio.service
Jan 15 19:38:41 voip-11 systemd1: Failed to start Kamailio (OpenSER) - the Open Source SIP Server.
Jan 15 19:38:41 voip-11 systemd1: Unit kamailio.service entered failed state.
Jan 15 19:38:41 voip-11 systemd1: kamailio.service failed.

asterisk -vvvvvr DONE AND HERE THE OUT PUT

Connected to Asterisk 13.17.2-vici currently running on voip-11 (pid = 1508)
Manager 'sendcron' logged on from 127.0.0.1
Manager 'sendcron' logged off from 127.0.0.1
Manager 'sendcron' logged on from 127.0.0.1
Manager 'sendcron' logged off from 127.0.0.1

AT THIS POINT, THE INSTLATION GET AN ERROR, WHE I TRIED TO GO TO MY FQDN ON MY BROWSER I GOT THIS ERROR
"MYSQL HOST IS NOT SET"

IN ORTHER TO FIX IT I FOLLOW THIS GUIDE

https://goautodial.org/projects/goautodialce/wiki/HOWTO_Update_latest_version_via_Github NOW I CAN SEE MY SYSTEM LOGIN

LOG IN AS ADMIN: DONE

https://go.callebisu.com
USER: goadmin
PASSWORD: G0autodial2018

ADMINISTRATION>SETTINGS: DONE

Change Base URL to your FQDN DONE, go.callebisu.com
Change Company Name
Change Timezone

ADMINISTRATION>GOWEBRTCSETTINGS: DONE

Change WebRTC Websocket to FQDN
Change WebRTC SIP Host/IP to FQDN
Change Kamailio Domain to FQDN

SETTINGS>SERVERS: DONE

Advanced Settings:
Generate Conf Files: YES
Rebuild Conf Files: YES
Rebuild Music On Hold: YES
Alt Recording Server IP: FQDN
External Server IP: FQDN

SETTINGS>CARRIERS: DONE

Create new SIP carrier (be sure to use 10 digits for DIAL PREFIX)

TELEPHONY>CAMPAIGNS>TEST CAMPAIGN: DONE

Change to Dial Method MANUAL
Change Carrier to use for this Campaign to the newly created carrier
Change to 24hr dialing

REBOOT TO BE SURE NEW CONFIG FILES ARE USED: DONE

reboot

TELEPHONY>USERS: DONE

Create NEW ADMIN USER
Delete agent001 and create NEW USER

NOW YOU SHOULD HAVE A FULLY FUNCTIONAL GOAUTODIAL INSTANCE WITH FQDN: NO I DON'T HAVE IT

In INCOGNITO browser, Login as newly created agent and test calls HERE I HAVE THIS ERROR, THE CAMPAING SELECTION GET FREEZZ

So Up to this point I have tried everything, every possible guide and still I have the problem that the selection of campaigns is stagnant or frozen and is saying "loggin in to your phone, please wait" (image Added)

HERE KAMAILIO LOGS:

0(11844) INFO: <core> [main.c:1934]: main(): private (per process) memory: 8388608 bytes
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: 35.184.193.92!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: go.callebisu.com!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: 8080!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: 4443!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: 9080!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: tcp:35.184.193.92:8080!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: tls:35.184.193.92:4443!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: tls:35.184.193.92:9080!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: 1800!g
0(11844) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: 3600!g
loading modules under config path: /usr/lib64/kamailio/modules/
0(11844) INFO: tls [tls_init.c:497]: init_tls_compression(): tls: init_tls: disabling compression...
0(11844) INFO: <core> [core/sctp_core.c:75]: sctp_core_check_support(): SCTP API not enabled - if you want to use it, load sctp module
Listening on
udp: 127.0.0.1:5060
udp: 35.184.193.92:5060
tcp: 35.184.193.92:5060
tcp: 35.184.193.92:8080
tls: 35.184.193.92:5061
tls: 35.184.193.92:4443
tls: 35.184.193.92:9080
Aliases:
udp: vaglxc01.goautodial.com:5060
udp: localhost4.localdomain4:5060
udp: localhost4:5060
udp: localhost.localdomain:5060
udp: localhost:5060
: callebisu.com:
: go.callebisu.com:

0(11844) INFO: <core> [core/tcp_main.c:4671]: init_tcp(): using epoll_lt as the io watch method (auto detected)
0(11847) INFO: rr [../outbound/api.h:52]: ob_load_api(): unable to import bind_ob - maybe module is not loaded
0(11847) INFO: rr [rr_mod.c:175]: mod_init(): outbound module not available
0(11847) INFO: tls [tls_mod.c:365]: mod_init(): With ECDH-Support!
0(11847) INFO: tls [tls_mod.c:368]: mod_init(): With Diffie Hellman
0(11847) INFO: cfgutils [cfgutils.c:780]: mod_init(): no hash_file given, disable hash functionality
0(11847) INFO: pike [pike.c:99]: pike_init(): PIKE - initializing
0(11847) INFO: pike [ip_tree.c:81]: init_lock_set(): probing 256 set size
0(11847) INFO: tls [tls_init.c:708]: init_tls_h(): tls: _init_tls_h: compiled with openssl version "OpenSSL 1.0.2k-fips 26 Jan 2017" (0x100020bf), kerberos support: on, compression: on
0(11847) INFO: tls [tls_init.c:716]: init_tls_h(): tls: init_tls_h: installed openssl library version "OpenSSL 1.0.2k-fips 26 Jan 2017" (0x100020bf), kerberos support: on, zlib compression: on
compiler: gcc -I. -I.. -I../include -fPIC -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DKRB5_MIT -m64 -DL_ENDIAN -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -Wa,--noexecstack -DPURIFY -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_MONT5 -DOPENSSL_BN_ASM_GF2m -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM -DVPAES_ASM -DBSAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM -DECP_NISTZ256_ASM
0(11847) WARNING: tls [tls_init.c:773]: init_tls_h(): tls: openssl bug #1491 (crash/mem leaks on low memory) workaround enabled (on low memory tls operations will fail preemptively) with free memory thresholds 14155776 and 7077888 bytes
0(11847) INFO: <core> [core/cfg/cfg_ctx.c:608]: cfg_set_now(): INFO: cfg_set_now(): tls.low_mem_threshold1 has been changed to 14155776
0(11847) INFO: <core> [core/cfg/cfg_ctx.c:608]: cfg_set_now(): INFO: cfg_set_now(): tls.low_mem_threshold2 has been changed to 7077888
0(11847) INFO: <core> [core/udp_server.c:153]: probe_max_receive_buffer(): SO_RCVBUF is initially 212992
0(11847) INFO: <core> [core/udp_server.c:203]: probe_max_receive_buffer(): SO_RCVBUF is finally 425984
0(11847) INFO: <core> [core/udp_server.c:153]: probe_max_receive_buffer(): SO_RCVBUF is initially 212992
0(11847) INFO: <core> [core/udp_server.c:203]: probe_max_receive_buffer(): SO_RCVBUF is finally 425984
0(11847) ERROR: <core> [core/udp_server.c:387]: udp_init(): bind(a, 0x7f64d90537b4, 16) on 35.184.193.92: Cannot assign requested address
0(11847) INFO: <core> [core/sctp_core.c:53]: sctp_core_destroy(): SCTP API not initialized

[root@go soporte_ebisu]# kamctl restart
database engine 'MYSQL' loaded
Control engine 'RPCFIFO' loaded

INFO: Stopping Kamailio :

ERROR: No PID file found (/var/run/kamailio/kamailio.pid)! Kamailio probably not running
INFO: check with 'ps axw | /bin/egrep kamailio'

Any one have any ideo whats i going on here?
I really need help with this.

error.PNG (124 KB) error.PNG

Replies (15)

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Wittie Manansala about 2 years ago

Hi,

It seems you forgot to install SSL certificate in your server.

Thanks

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Vericar De Espiritu Santo about 2 years ago

Wittie Manansala wrote:

Hi,

It seems you forgot to install SSL certificate in your server.

Thanks

Do you Think, certbot can fix the problem? Cuz, I'm triying do that, but i get an error when i try to use a certbot.

[root@go soporte_ebisu]# certbot --apache -d go.callebisu.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter 'c' to
cancel):
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v02.api.letsencrypt.org/directory
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: A

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: N
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for go.callebisu.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Wittie Manansala about 2 years ago

Vericar De Espiritu Santo wrote:

Wittie Manansala wrote:

Hi,

It seems you forgot to install SSL certificate in your server.

Thanks

Do you Think, certbot can fix the problem? Cuz, I'm triying do that, but i get an error when i try to use a certbot.

[root@go soporte_ebisu]# certbot --apache -d go.callebisu.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter 'c' to
cancel):
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v02.api.letsencrypt.org/directory
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: A

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: N
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for go.callebisu.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

Please visit https://goautodial.org/boards/3/topics/14555

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Vericar De Espiritu Santo about 2 years ago

Wittie Manansala wrote:

Vericar De Espiritu Santo wrote:

Wittie Manansala wrote:

Hi,

It seems you forgot to install SSL certificate in your server.

Thanks

Do you Think, certbot can fix the problem? Cuz, I'm triying do that, but i get an error when i try to use a certbot.

[root@go soporte_ebisu]# certbot --apache -d go.callebisu.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter 'c' to
cancel):
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v02.api.letsencrypt.org/directory
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: A

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: N
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for go.callebisu.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

Please visit https://goautodial.org/boards/3/topics/14555

I'am active in that topic too, the problem is that certbot is asking for a Virtual Host Listenin on port 80 and i don't know how to do it...

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Vericar De Espiritu Santo about 2 years ago

Wittie Manansala wrote:

Vericar De Espiritu Santo wrote:

Wittie Manansala wrote:

Hi,

It seems you forgot to install SSL certificate in your server.

Thanks

Do you Think, certbot can fix the problem? Cuz, I'm triying do that, but i get an error when i try to use a certbot.

[root@go soporte_ebisu]# certbot --apache -d go.callebisu.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter 'c' to
cancel):
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v02.api.letsencrypt.org/directory
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: A

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: N
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for go.callebisu.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

Please visit https://goautodial.org/boards/3/topics/14555

Ready, place the ssl certificate and still continue the error. I can't correct it, kamailio continues in a failed state and I can't make progress in the campaign selection. Could someone give me the solution?

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Hafedh Gouaida over 1 year ago

Hi everyone,

can someone explain me this part plz :
hostnamectl set-hostname xxxxxx.xxxxx.xxx
vi /etc/hosts
change domain name for actual server ip (xxx.xxx.xxx.xxx complete domain name subdomain only)

What i have to put on hostnamectl set-hostname? My Public Ip? My domain ?

and here :
vi /etc/hosts
change domain name for actual server ip (xxx.xxx.xxx.xxx complete domain name subdomain only)

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

Whitch one i have to change ? can you give me an exemple plz

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Leopoldo Martinez over 1 year ago

Hafedh Gouaida wrote:

Hi everyone,

can someone explain me this part plz :
hostnamectl set-hostname xxxxxx.xxxxx.xxx
vi /etc/hosts
change domain name for actual server ip (xxx.xxx.xxx.xxx complete domain name subdomain only)

What i have to put on hostnamectl set-hostname? My Public Ip? My domain ?

Here you have to put you domain. autodial.example.com

and here :
vi /etc/hosts
change domain name for actual server ip (xxx.xxx.xxx.xxx complete domain name subdomain only)

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

Whitch one i have to change ? can you give me an exemple plz

if you dont see a line that contain your server ip and you subdomain you must add it

190.123.123.123 autodial.example.com

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Hafedh Gouaida over 1 year ago

First of all thank you a lot.
I can login now.

But after i installed certbot and changed the path for the certificate i restarted kamelio and it was green.
But short time after i got :

mariadb.service failed.
juin 08 17:44:45 myDomain systemd[1]: Unit mariadb.service entered failed state.
juin 08 17:44:45 myDomain systemd[1]: Failed to start MariaDB 10.1.36 database server.
juin 08 17:44:45 myDomain systemd[1]: mariadb.service: main process exited, code=killed, status=11/SEGV
juin 08 17:44:44 myDomain mysqld[3665]: 2020-06-08 17:44:44 139805475588352 [Note] /usr/sbin/mysqld (mysqld 10.1.36-MariaDB) starting as process 3665 ...
juin 08 17:44:44 myDomain mysqld[3665]: 2020-06-08 17:44:44 139805475588352 [Note] Using unique option prefix 'max_heap_table' is error-prone and can break in the future. Please use 
juin 08 17:44:44 myDomain systemd[1]: Starting MariaDB 10.1.36 database server...
juin 08 17:44:44 myDomain systemd[1]: Stopped MariaDB 10.1.36 database server.
juin 08 17:44:44 myDomain systemd[1]: mariadb.service holdoff time over, scheduling restart.
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1648]: ERROR: auth_db [authorize.c:178]: get_ha1(): failed to query database
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1648]: ERROR: <core> [db_query.c:132]: db_do_query_internal(): error while submitting query
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1648]: ERROR: db_mysql [km_dbase.c:128]: db_mysql_submit_query(): driver error on query: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111 "Connection refused") (2002)
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1646]: ERROR: auth_db [authorize.c:178]: get_ha1(): failed to query database
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1646]: ERROR: <core> [db_query.c:132]: db_do_query_internal(): error while submitting query
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1646]: ERROR: db_mysql [km_dbase.c:128]: db_mysql_submit_query(): driver error on query: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111 "Connection refused") (2002)
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1647]: ERROR: auth_db [authorize.c:178]: get_ha1(): failed to query database
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1647]: ERROR: <core> [db_query.c:132]: db_do_query_internal(): error while submitting query
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1647]: ERROR: db_mysql [km_dbase.c:128]: db_mysql_submit_query(): driver error on query: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111 "Connection refused") (2002)
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1645]: ERROR: auth_db [authorize.c:178]: get_ha1(): failed to query database
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1645]: ERROR: <core> [db_query.c:132]: db_do_query_internal(): error while submitting query
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1645]: ERROR: db_mysql [km_dbase.c:128]: db_mysql_submit_query(): driver error on query: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111 "Connection refused") (2002)
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1648]: ERROR: auth_db [authorize.c:178]: get_ha1(): failed to query database
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1648]: ERROR: <core> [db_query.c:132]: db_do_query_internal(): error while submitting query
juin 08 17:44:40 myDomain /usr/sbin/kamailio[1648]: ERROR: db_mysql [km_dbase.c:128]: db_mysql_submit_query(): driver error on query: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111 "Connection refused") (2002)
juin 08 17:44:39 myDomain systemd[1]: mariadb.service failed.

Someone have a hint for me ?

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Leopoldo Martinez over 1 year ago

Sorry, at this point i dont use cert, bur here you are a hint, other user make it works.

this is the link
https://goautodial.org/boards/3/topics/18690?r=18705#message-18705

and i quot his post

David Reedy wrote:

Hello everyone,

I have been fighting with GOautodail SSL for the past week. Today i finally have a working model and wanted to share with everyone what settings worked for me.

This server is behind a NAT.

etc/kamailio/kamailio.cfg

MY_IP_ADDR!"internal IP address"!g ----exclude""
MY_DOMAIN!"external dns that is linked to external IP address"!g ---exclude ""

alias="internal IP address"
alias="External DNS"

listen=udp:"Internal IP address":5060 ---exclude ""
listen=udp:127.0.0.1:5060

modparam("rtpengine", "rtpengine_sock", "udp:"Ineternal IP address":5066") ---exclude ""

etc/kamailio/tls.cfg
[server:default]
method = TLSv1
private_key = /etc/letsencrypt/live/DNS/privkey.pem
certificate = /etc/letsencrypt/live/DNS/cert.pem

#private_key = /etc/pki/tls/private/localhost.key --- make sure to mark off these 2 items. so that the system doesn't use them.
#certificate = /etc/pki/tls/certs/localhost.crt

/etc/rtpengine/rtpengine.conf

interface = internal IP address

listen-ng = "Internal IP addres":5066 --- except ""

/etc/asterisk/sip-goautodial.cfg

host=+localhost+ ;change me to my FQDN
--- the host is for the registration of the phone to the asterisk. without this you will get a 407 proxy error. My setup is behind a firewall and NAT'd.

Make sure if you are using a CERT that the

vi /var/www/html/php/goCRMAPISettings.php

matches the CERT name.

I think that does it for all the CLI settings that i had to change.

This next stage is on the admin web section of the GOautodial.

Administration-->GoWebRTC DIaler Settings

WebRTC Websocket HOST/IP

External DNS -- make sure that if you are using a certificate that the host name of the cert is what is used here. without the DNS you will get that nasty ERR_CERT

WebRTC SIP Host/IP

Internal IP address

Kamailio Domain

Internal IP address

After all the setting have been changed I find that a system reboot is needed. Once the system is back up check asterisk -vvvr
and see if "sip show peers" has kamailio registered.

kamailio 127.0.0.1 Yes Yes 5060 OK (1 ms)

Make a test call and see how it goes. Good luck.

I am pretty new to this forum so i hope this helps. If i have something incorrect let me know.

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Hafedh Gouaida over 1 year ago

Leopoldo Martinez wrote:

Sorry, at this point i dont use cert, bur here you are a hint, other user make it works.

this is the link
https://goautodial.org/boards/3/topics/18690?r=18705#message-18705

and i quot his post

David Reedy wrote:

Hello everyone,

I have been fighting with GOautodail SSL for the past week. Today i finally have a working model and wanted to share with everyone what settings worked for me.

This server is behind a NAT.

etc/kamailio/kamailio.cfg

MY_IP_ADDR!"internal IP address"!g ----exclude""
MY_DOMAIN!"external dns that is linked to external IP address"!g ---exclude ""

alias="internal IP address"
alias="External DNS"

listen=udp:"Internal IP address":5060 ---exclude ""
listen=udp:127.0.0.1:5060

modparam("rtpengine", "rtpengine_sock", "udp:"Ineternal IP address":5066") ---exclude ""

etc/kamailio/tls.cfg
[server:default]
method = TLSv1
private_key = /etc/letsencrypt/live/DNS/privkey.pem
certificate = /etc/letsencrypt/live/DNS/cert.pem

#private_key = /etc/pki/tls/private/localhost.key --- make sure to mark off these 2 items. so that the system doesn't use them.
#certificate = /etc/pki/tls/certs/localhost.crt

/etc/rtpengine/rtpengine.conf

interface = internal IP address

listen-ng = "Internal IP addres":5066 --- except ""

/etc/asterisk/sip-goautodial.cfg

host=+localhost+ ;change me to my FQDN
--- the host is for the registration of the phone to the asterisk. without this you will get a 407 proxy error. My setup is behind a firewall and NAT'd.

Make sure if you are using a CERT that the

vi /var/www/html/php/goCRMAPISettings.php

matches the CERT name.

I think that does it for all the CLI settings that i had to change.

This next stage is on the admin web section of the GOautodial.

Administration-->GoWebRTC DIaler Settings

WebRTC Websocket HOST/IP

External DNS -- make sure that if you are using a certificate that the host name of the cert is what is used here. without the DNS you will get that nasty ERR_CERT

WebRTC SIP Host/IP

Internal IP address

Kamailio Domain

Internal IP address

After all the setting have been changed I find that a system reboot is needed. Once the system is back up check asterisk -vvvr
and see if "sip show peers" has kamailio registered.

kamailio 127.0.0.1 Yes Yes 5060 OK (1 ms)

Make a test call and see how it goes. Good luck.

I am pretty new to this forum so i hope this helps. If i have something incorrect let me know.

Thank you for your answer but how did you do to not use certbot? when i go on my website without cert i got a Certificate error, and i have to allow the browser to go on the website? We can use another thing to bypass this ?

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Leopoldo Martinez over 1 year ago

As I say before, i'm working without cert, allowing the browser go to the "non secure" site. This weekend I'll try to put a cert, if i can figured it out, I'll post here the process.

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Hafedh Gouaida over 1 year ago

Leopoldo Martinez wrote:

As I say before, i'm working without cert, allowing the browser go to the "non secure" site. This weekend I'll try to put a cert, if i can figured it out, I'll post here the process.

Ok thank you.
If i success i will write it too

RE: Problem With Kamailio adn Dialer -- Scratch Installation FQDN - Added by Alfred Vilsmeier over 1 year ago

Hafedh Gouaida wrote:

Leopoldo Martinez wrote:

As I say before, i'm working without cert, allowing the browser go to the "non secure" site. This weekend I'll try to put a cert, if i can figured it out, I'll post here the process.

Ok thank you.
If i success i will write it too

Hi Leopoldo, were you able to get it to work with TLS?
I've been banging my head trying to get this to work on AWS EC2 but there's isn't a single clear step by step guide on how to do this, documentation is VERY vague, no hints as to if you should use internal or external IP.
I followed David Reedy's article but i was still unable to make it work.

The furthest I got was to actually login to the campaign with an agent, but when I tried placing a call all I get is "No leads in the campaign", and asterisk sees absolutely no traffic from kamailio other than keepalives.
The funny thing is that I even tried with the AMI, which can only be launched within a VPC (NAT) and there ins't a single hint as to how to properly set it up. I'm REALLY frustrated with Gov4 so far.
In my humble opinion an AMI should just WORK out of the box, or at least allow you to login as an agent and fire up a webphone without having to melt your brains for 2 days.
None of the default passwords or my "instance id" worked for goadmin, so I had to manually reset the password via mysql.
I guess I'll just fire up another instance, perhaps I'll just try to install from scratch this time, paying USD75 a month for the AMI when it just won't work is a bit too much for me.
Goautodial team, could someone PLEASE post a working step by step guide to setup a server in EC2 using the AMI or behind NAT at least. Also please confirm what is actually the default password for the AMI, thank you!

    (1-15/15)
    Go to top