Project

General

Profile

Trunks / Carrier not created - GOautodial v4 ISO install

Added by Jose Capurro 3 months ago

Hello there!

I have installed GOautodial v4 using the preview ISO.

I was trying to create a new SIP trunk via Settings > Carriers, and selecting Carrier Type as Manual.

After i create the carrier i do not see any indication of it been created in Asterisk nor Kamailio, after checking in the configuration files
and in the subscriber table.

My ultimate goal is to create an inbound campaign. The ingroup and DID are already created.

Though i can not see the trunk been created in GOautodial, i configured a matching SIP trunk in my another Asterisk server who acts as my gateway.

It is in production with some 50 extensions and 3 trunks for different destinations.

The thing i have noticed is that in kamailio.cfg there is no route to relay calls to the Asterisk running in GOautodial.

Is there a way to configure a functioning trunk in GOautodial?

Attached are the configuration for the trunks. There is no iptables running or anything like that.


Replies (12)

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Wittie Manansala 3 months ago

Hi,

Please provide the following information:

1. sip show registry
2. sip show peers
3. service kamailio status

If no output displayed in 1 and 2 try run core reload or module reload. If kamailio status is failed try to run service kamailio restart.

Thanks

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Jose Capurro 3 months ago

https://pastebin.com/raw/h7EXjWrQ

As requested, the output for those commands.

Kamailio is up. As an agent, i can login to the dialer.

Asterisk is up, and the only peer is kamailio.

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Jose Capurro 3 months ago

The other thing is, i do not see activity in Kamailio.

I have set WITH_DEBUG in kamailio.cfg, but when i try to make calls from the WebRTC phone, there is no activity.

The only thing i see are the pings for the WebRTC connection and the OPTIONS used to qualify with the GOautodial's Asterisk.

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Demian Biscocho 3 months ago

Can you post the output of:

screen -ls

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Jose Capurro 3 months ago

There are screens on:
16754.ASTemail (Detached)
21056.ASTVDadapt (Detached)
27424.ASTVDremote (Detached)
4422.ASTVDadFILL (Detached)
4413.ASTVDauto (Detached)
4410.ASTlisten (Detached)
4407.ASTsend (Detached)
4404.ASTupdate (Detached)
4229.asterisk (Detached)
4224.astshell20181122160531 (Detached)
10 Sockets in /var/run/screens/S-root.

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Demian Biscocho 3 months ago

You should see the SIP carrier created in the Asterisk CLI:

sip show peers

This should show the active carriers in your v4 system.

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by amir mustafa 2 months ago

Hi,

after adding sip trunk im getting this error on asterisk Cli. server dial calls but only dial last 3 digits of the number (-- Called SIP/179@tele) as you can see in the log.

vaglxc01*CLI> sip show registry
Host dnsmgr Username Refresh State Reg.Time
x.x.x.x:5060 N mtelebridge 45 Registered Thu, 20 Dec 2018 12:03:18
1 SIP registrations.
vaglxc01*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
kamailio 127.0.0.1 Yes Yes 5060 OK (1 ms)
tele/mtelebridge 1x.x2.xx8.x Yes Yes 5060 OK (332 ms)
2 sip peers [Monitored: 2 online, 0 offline Unmonitored: 0 online, 0 offline]

My dial Plan

exten => _999.,1,AGI
exten => _999.,2,Dial(SIP/${EXTEN:10}@teleusa,,tTo)
exten => _999.,3,Hangup

Asterisk CLI
___________________________________________________________________

Manager 'sendcron' logged on from 127.0.0.1
-- Executing [9992126636179@default:1] AGI("Local/9992126636179@default-00000080;2", "agi://127.0.0.1:4577/call_log") in new stack
-- Called 9992126636179@default
-- AGI Script Executing Application: (EXEC) Options: (Set(CAMPCUST=12904133))
-- <Local/9992126636179@default-00000080;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing [9992126636179@default:2] Dial("Local/9992126636179@default-00000080;2", "SIP/179@tele,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/179@tele
-- Got SIP response 500 "Server Internal Error" back from 1x.x.x.x:5060
-- SIP/tele-0000006f is circuit-busy
Everyone is busy/congested at this time (1:0/1/0)
-- Executing [9992126636179@default:3] Hangup("Local/9992126636179@default-00000080;2", "") in new stack
Spawn extension (default, 9992126636179, 3) exited non-zero on 'Local/9992126636179@default-00000080;2'
-- Executing [h@default:1] AGI("Local/9992126636179@default-00000080;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----38-----CONGESTION---------------SIP 500 Server Internal Error)") in new stack
-- <Local/9992126636179@default-00000080;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----38-----CONGESTION---------------SIP 500 Server Internal Error) completed, returning 0
_______________________________________________________

Regards,

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Levy Ryan Nolasco 2 months ago

It is because of dial plan EXTEN:10

Try adding 7 more digits on your dial plan or change 10 to 3.

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by amir mustafa 2 months ago

Thank you so much for your response.
After changing exten 10 to 3 numbers dial properly and call connect in the background but not transfer to the agent.

  1. screen -ls
    There are screens on:
    22012.pts-8.vaglxc01 (Attached)
    17818.ASTVDadapt (Detached)
    2019.ASTVDremote (Detached)
    2016.ASTVDauto (Detached)
    2013.ASTlisten (Detached)
    2010.ASTsend (Detached)
    2007.ASTupdate (Detached)
    1839.asterisk (Detached)
    1779.ASTfastlog (Detached)
    9 Sockets in /var/run/screen/S-root.

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by amir mustafa 2 months ago

amir mustafa wrote:

Thank you so much for your response.
After changing exten 10 to 3 numbers dial properly and call connect in the background but not transfer to the agent.

  1. screen -ls
    There are screens on:
    22012.pts-8.vaglxc01 (Attached)
    17818.ASTVDadapt (Detached)
    2019.ASTVDremote (Detached)
    2016.ASTVDauto (Detached)
    2013.ASTlisten (Detached)
    2010.ASTsend (Detached)
    2007.ASTupdate (Detached)
    1839.asterisk (Detached)
    1779.ASTfastlog (Detached)
    9 Sockets in /var/run/screen/S-root.

Asterisk CLI output:
__________________________________________________________________
-- Called 99913153960506@default
-- Executing [99913153960506@default:1] AGI in new stack
-- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=12904133))
Manager 'sendcron' logged on from 127.0.0.1
-- <Local/99913153960506@default-000001e2;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing [99913153960506@default:2] Dial("Local/99913153960506@default-000001e2;2", "SIP/13153960506@tele,,tTo") in new stack
-- Called 99917182944832@default
-- Executing [99917182944832@default:1] AGI("Local/99917182944832@default-000001e3;2", "agi://127.0.0.1:4577/call_log") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/13153960506@tele
-- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=12904133))
-- <Local/99917182944832@default-000001e3;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing [99917182944832@default:2] Dial("Local/99917182944832@default-000001e3;2", "SIP/17182944832@tele,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/17182944832@tele
Manager 'sendcron' logged on from 127.0.0.1
-- Called 99918139330680@default
-- Executing [99918139330680@default:1] AGI in new stack
-- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=12904133))
-- <Local/99918139330680@default-000001e4;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing [99918139330680@default:2] Dial("Local/99918139330680@default-000001e4;2", "SIP/18139330680@tele,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/18139330680@tele
Manager 'sendcron' logged on from 127.0.0.1
-- Called 99918138544780@default
-- Executing [99918138544780@default:1] AGI in new stack
-- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=12904133))
-- <Local/99918138544780@default-000001e5;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing [99918138544780@default:2] Dial("Local/99918138544780@default-000001e5;2", "SIP/18138544780@tele,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/18138544780@tele
-- SIP/tele-000001c5 is ringing
-- Local/99913153960506@default-000001e2;1 is ringing
-- Got SIP response 500 "Server Internal Error" back from 10.02.08.0:5060
-- SIP/tele-000001c8 is circuit-busy
Everyone is busy/congested at this time (1:0/1/0)
-- Executing [99918138544780@default:3] Hangup("Local/99918138544780@default-000001e5;2", "") in new stack
Spawn extension (default, 99918138544780, 3) exited non-zero on 'Local/99918138544780@default-000001e5;2'
-- Executing [h@default:1] AGI("Local/99918138544780@default-000001e5;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----38-----CONGESTION---------------SIP 500 Server Internal Error)") in new stack
-- &lt;Local/99918138544780@default-000001e5;2&gt;AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----38-----CONGESTION---------------SIP 500 Server Internal Error) completed, returning 0
Manager 'sendcron' logged off from 127.0.0.1
Manager 'sendcron' logged on from 127.0.0.1
-- Executing [55558600052@default:1] Hangup("Local/55558600052@default-000001e6;2", "") in new stack
-- Called 55558600052@default
Spawn extension (default, 55558600052, 1) exited non-zero on 'Local/55558600052@default-000001e6;2'
[Dec 21 06:10:37] WARNING23751[C-0000020b]: func_hangupcause.c:140 hangupcause_read: Unable to find information for channel
-- Executing [h@default:1] AGI") in new stack
-- <Local/55558600052@default-000001e6;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16--------------------) completed, returning 0
Manager 'sendcron' logged off from 127.0.0.1
Spawn extension (default, 99913153960506, 2) exited non-zero on 'Local/99913153960506@default-000001e2;2'
-- Executing [h@default:1] AGI") in new stack
Manager 'sendcron' logged off from 127.0.0.1
Spawn extension (default, 99917182944832, 2) exited non-zero on 'Local/99917182944832@default-000001e3;2'
Manager 'sendcron' logged off from 127.0.0.1
-- Executing [h@default:1] AGI("Local/99917182944832@default-000001e3;2", "agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0-----CANCEL---------------SIP 100 Trying)") in new stack
Spawn extension (default, 99918139330680, 2) exited non-zero on 'Local/99918139330680@default-000001e4;2' == Manager 'sendcron' logged off from 127.0.0.1
-- Executing [h@default:1] AGI") in new stack
-- <Local/99913153960506@default-000001e2;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0-----CANCEL---------------SIP 180 Ringing) completed, returning 0
-- <Local/99917182944832@default-000001e3;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0-----CANCEL---------------SIP 100 Trying) completed, returning 0
-- <Local/99918139330680@default-000001e4;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0-----CANCEL---------------SIP 100 Trying) completed, returning 0

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by jo n about 1 month ago

amir mustafa wrote:

Hi,

after adding sip trunk im getting this error on asterisk Cli. server dial calls but only dial last 3 digits of the number (-- Called SIP/179@tele) as you can see in the log.

vaglxc01*CLI> sip show registry
Host dnsmgr Username Refresh State Reg.Time
x.x.x.x:5060 N mtelebridge 45 Registered Thu, 20 Dec 2018 12:03:18
1 SIP registrations.
vaglxc01*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
kamailio 127.0.0.1 Yes Yes 5060 OK (1 ms)
tele/mtelebridge 1x.x2.xx8.x Yes Yes 5060 OK (332 ms)
2 sip peers [Monitored: 2 online, 0 offline Unmonitored: 0 online, 0 offline]

My dial Plan

exten => _999.,1,AGI
exten => _999.,2,Dial(SIP/${EXTEN:10}@teleusa,,tTo)
exten => _999.,3,Hangup

Asterisk CLI
___________________________________________________________________

== Manager 'sendcron' logged on from 127.0.0.1
-- Executing [9992126636179@default:1] AGI in new stack
-- Called 9992126636179@default
-- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=12904133))
-- <Local/9992126636179@default-00000080;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
-- Executing [9992126636179@default:2] Dial("Local/9992126636179@default-00000080;2", "SIP/179@tele,,tTo") in new stack
Using SIP RTP CoS mark 5
-- Called SIP/179@tele
-- Got SIP response 500 "Server Internal Error" back from 1x.x.x.x:5060
-- SIP/tele-0000006f is circuit-busy
Everyone is busy/congested at this time (1:0/1/0)
-- Executing [9992126636179@default:3] Hangup("Local/9992126636179@default-00000080;2", "") in new stack == Spawn extension (default, 9992126636179, 3) exited non-zero on 'Local/9992126636179@default-00000080;2'
-- Executing [h@default:1] AGI") in new stack
-- <Local/9992126636179@default-00000080;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----38-----CONGESTION---------------SIP 500 Server Internal Error) completed, returning 0
______________________________________________________

Regards,

hello
how did you get the SIP trunk to work?

RE: Trunks / Carrier not created - GOautodial v4 ISO install - Added by Wittie Manansala 30 days ago

Hi,

Try to change this:

From:
exten => _999.,1,AGI
exten => _999.,2,Dial(SIP/${EXTEN:10}@teleusa,,tTo)
exten => _999.,3,Hangup

To:
exten => _999.,1,AGI
exten => _999.,2,Dial(SIP/${EXTEN:3}@teleusa,,tTo)
exten => _999.,3,Hangup

Thanks

    (1-12/12)
    Go to top