Project

General

Profile

Problem uploading leads

Added by Rohan Bhajekar about 5 years ago

Hi guys,

I have installed goautodial on a remote server with CentOS 7. I am experiencing problems uploading leads. When i upload my csv or xlsx file all fields get listed below bu the values in the dropdown is either none or "" . I am trying to fix this issue for days now but found nothing significant.

Any helps is much appreciated.

TIA
Rohan


Replies (12)

RE: Problem uploading leads - Added by striker 247 about 5 years ago

Hi

Did you tried to uplaod text tab delimated format file instead of csv/excel

check this link [[http://striker24x7.blogspot.in/2012/03/vicidialgoautodial-lead-format-sample.html]]

if you really want to upload csv /xlsx then make sure below cpan modules are installed in your goautodial
- install Unicode::Map (needed for super list loader Excel)
- install Jcode (needed for super list loader Excel)
- install Spreadsheet::WriteExcel (needed for super list loader Excel)
- install OLE::Storage_Lite (needed for super list loader Excel)
- install Proc::ProcessTable (needed for super list loader Excel)
- install IO::Scalar (needed for super list loader Excel)
- install Spreadsheet::ParseExcel (needed for super list loader Excel)

regards
striker
www.striker24x7.blogspot.com

RE: Problem uploading leads - Added by Rohan Bhajekar about 5 years ago

Hi Striker,

I am using your sample file to upload. I also did performed your suggested steps but when i upload my csv or xls file it gets uploaded values in dropdown for each column in the csv has "" blank value. There are almost 30 odd dummy records to test it out. Do i need to reboot my remote server after installation of these modules. ?

Your help is much appreciated.

TIA
Rohan

RE: Problem uploading leads - Added by striker 247 about 5 years ago

after filling the sample file, did u saved the file as text tab delimated format?

try to upload the file via vicidial admin page ie: http://ip/vicidial/admin.php
- list - upload list

regards
striker
www.striker24x7.blogspot.com

RE: Problem uploading leads - Added by Rohan Bhajekar about 5 years ago

The application does not allow me to upload Text/Tab delimated file. It only allows csv , xls & xlsx formats.

I am unable to setup vicidial password. I did follow all the steps but one thing concerns me is that how mariadb and mysql co-exist on the same server. ?

regards
Rohan

RE: Problem uploading leads - Added by Rohan Bhajekar about 5 years ago

Any help on this is really much appreciated because i am 100% stuck on this issue. I am pretty sure this is something related to configuration. But need aome expert advise.

TIA
Rohan

RE: Problem uploading leads - Added by Rohan Bhajekar about 5 years ago

Dear Mr. Striker,

I tried the same on http://$ip_address/vicidial/admin.php but i still get the same error. "ERROR: The file does not have the required number of fields to process it."

Can you please guide me. I have installed all CPAN modules described here http://striker24x7.blogspot.ca/2016/01/vicdial-asterisk-11-scratch-install-in.html

Any help is appreciated.

Regards,
Rohan

RE: Problem uploading leads - Added by Rohan Bhajekar about 5 years ago

striker 247 wrote:

after filling the sample file, did u saved the file as text tab delimated format?

try to upload the file via vicidial admin page ie: http://ip/vicidial/admin.php
- list - upload list

regards
striker
www.striker24x7.blogspot.com

Dear Mr. Striker,

I tried the same on http://$ip_address/vicidial/admin.php but i still get the same error when i upload any csv or xls file. "ERROR: The file does not have the required number of fields to process it.". Having said that i tried uploading text-tab delimated file and it worked but cantsee those leads in goautodial. So still i am kind of 100% stuck and cannot use this application.

Can you please guide me. I have installed all CPAN modules described here http://striker24x7.blogspot.ca/2016/01/vicdial-asterisk-11-scratch-install-in.html

Any help is appreciated.

RE: Problem uploading leads - Added by Sajid Khan about 5 years ago

Rohan Bhajekar wrote:

Hi guys,

I have installed goautodial on a remote server with CentOS 7. I am experiencing problems uploading leads. When i upload my csv or xlsx file all fields get listed below bu the values in the dropdown is either none or "" . I am trying to fix this issue for days now but found nothing significant.

Any helps is much appreciated.

TIA
Rohan

New to goutodial
Just installed it
Having exactly the same issue
system not allowing me to upload Text/Tab delimited file
Will try installing cpan modules as mentioned above

tried downloading 'lead_format.xlsx' as mentioned above... if i try uploading it without any changes i cannot see the 'striker entry'

on the Dashboard i can see 3 active leads
but 0 leads in hopper

will try restarting the autodial services and check again

RE: Problem uploading leads - Added by Sajid Khan about 5 years ago

figured out my issue
make sure you update the list id number on the template spreadsheet against each new entry

i think the default list ID is 998

i created a List ID first.. e.g. 997 then updated the spreadsheet column 'list_id' with 997 against all entries. then went to campaign to create a new campaign and upload the template file
once template uploaded and processed all my entries uploaded

could not see lead in hopper however when i go to lists and search for a lead it displays fine

now i have to figure out how to log on with a agent and dial out

RE: Problem uploading leads - Added by james harris 3 months ago

Sajid Khan wrote in RE: Problem uploading leads:

figured out my issue
make sure you update the list id number on the template spreadsheet against each new entry

i think the default list ID is 998

i created a List ID first.. e.g. 997 then updated the spreadsheet column 'list_id' with 997 against all entries. then went to campaign to create a new campaign and upload the template file
once template uploaded and processed all my entries uploaded

could not see lead in hopper however when i go to lists and search for a lead it displays fine

now i have to figure out how to log on with a agent and dial out

I cant upload my leads , can u help ?

RE: Problem uploading leads - Added by Jackie Alfonso 3 months ago

james harris wrote in RE: Problem uploading leads:

Sajid Khan wrote in RE: Problem uploading leads:

figured out my issue
make sure you update the list id number on the template spreadsheet against each new entry

i think the default list ID is 998

i created a List ID first.. e.g. 997 then updated the spreadsheet column 'list_id' with 997 against all entries. then went to campaign to create a new campaign and upload the template file
once template uploaded and processed all my entries uploaded

could not see lead in hopper however when i go to lists and search for a lead it displays fine

now i have to figure out how to log on with a agent and dial out

I cant upload my leads , can u help ?

Hi James,

Please try to follow the steps here https://goautodial.org/projects/goautodialce/wiki/HowTo_Load_Leads_30
and make sure that you've follow the lead file format as well.

Thank you!

RE: Problem uploading leads - Added by Aric Joshua 3 months ago

Hello, James.

Please try to follow the procedures here and double-check that the lead file format is correct cookie clicker. Thank you very much!

    (1-12/12)
    Go to top