Project

General

Profile

form scratch bad sip pear

Added by zaqrt zaq 8 months ago

I have been following the https://goautodial.org/projects/goautodialce/wiki/Version_4_How_To_Install_Goautodial_From_Scratch_using_CentOS_7X
and i couldn't make calls so i reinstall the app again but i get the same error i think it have to do with this

*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
kamailio 104.254.128.211 Yes Yes 5060 OK (157 ms)

the 104.254.128.211 isnt my ip adress
firstly my kamilio wasnt starting but that had to do with rtpengine
had to change table 0 to table -1 in config

my configs are exacly like in the https://goautodial.org/projects/goautodialce/wiki/Version_4_How_To_Install_Goautodial_From_Scratch_using_CentOS_7X
only the ips are changed

anyone could help me ?
Thanks zaqrt


Replies (3)

RE: form scratch bad sip pear - Added by Wittie Manansala 8 months ago

Try to review your settings using the below guide:

https://goautodial.org/projects/goautodialce/wiki/Goautodial_Getting_Started_Guidev4 (Configuration Files)

RE: form scratch bad sip pear - Added by jesse wallick 3 months ago

zaqrt zaq wrote:

I have been following the https://goautodial.org/projects/goautodialce/wiki/Version_4_How_To_Install_Goautodial_From_Scratch_using_CentOS_7X
and i couldn't make calls so i reinstall the app again but i get the same error i think it have to do with this

*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
kamailio 104.254.128.211 Yes Yes 5060 OK (157 ms)

the 104.254.128.211 isnt my ip adress
firstly my kamilio wasnt starting but that had to do with rtpengine
had to change table 0 to table -1 in config

my configs are exacly like in the https://goautodial.org/projects/goautodialce/wiki/
only the ips are changed

anyone could help me ?
Thanks zaqrt

you’re facing a configuration issue with Kamailio where it’s not recognizing your IP address correctly. The IP address 104.254.128.211 showing up in your sip show peers output suggests that somewhere in your configuration, this external IP is being referenced instead of your intended local IP.

Here are a few steps you can take to troubleshoot this issue:

Check Kamailio Configuration: Ensure that the listen directive in your kamailio.cfg file is set to your server’s local IP address or hostname. It should look something like this:
listen=udp:your_local_ip:5060
Replace your_local_ip with the actual IP address of your server.
RTP Engine Configuration: Since you mentioned changing the RTP engine table from 0 to -1, make sure that this change is correctly reflected in your rtpengine configuration. This change typically disables kernel packet forwarding and uses userspace forwarding instead.
Firewall and Network Settings: Verify that your firewall settings are not blocking the SIP and RTP ports and that your network is correctly configured to route the traffic to your server.
Kamailio and RTPengine Logs: Check the logs for both Kamailio and RTPengine for any errors or warnings that could give more insight into the issue.
Kamailio Users and Permissions: Ensure that the Kamailio user has the correct permissions and that the user is configured correctly in the kamailio.cfg.
External IP Binding: If your server is behind NAT, you might need to configure Kamailio to handle NAT traversal. This can involve setting the advertised_address or force_send_socket parameters to ensure responses are sent from the correct IP address.
If after checking these steps the issue persists, you may want to consult the Goautodial community forums or the Kamailio user mailing list for more specific assistance, as they might have encountered similar issues and can provide more targeted support. Remember to provide them with as much detail as possible, including any error messages and configuration files. Good luck with your troubleshooting!

RE: form scratch bad sip pear - Added by Vicki Giles 3 months ago

Wittie Manansala wrote in RE: form scratch bad sip pear:

Try to review your settings using the below guide:

https://goautodial.org/projects/goautodialce/wiki/Goautodial_Getting_Started_Guidev4 (Configuration Files)

If you would like to reset all of your location settings to the factory default, go to Settings > General > Transfer or Reset [device], tap Reset, then tap Reset Location & Privacy.

    (1-3/3)
    Go to top