Project

General

Profile

Actions

Bug #9198

closed

Dispo Choice or Lead ID is NOT valid Error

Added by Sabri AKTALAY over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
02/20/2023
Due date:
% Done:

100%

Estimated time:

Description

I encountered an error on my newly installed Test server After updating via github , Whatever I choose on the dispo screen, it records as status A and shows the error ( Dispo Choice or Lead ID is NOT valid Error ) I realized that I am getting this error because of this file updated 2 weeks ago (modules/GOagent/GOagentJS.php)

I found the solution by replacing (modules/GOagent/GOagentJS.php) with an older version of this file


Files

2023-02-19_21-53-16.png (173 KB) 2023-02-19_21-53-16.png Sabri AKTALAY, 02/20/2023 02:58 AM
Actions #1

Updated by rotciv Pepperoni about 1 year ago

Having the same error, looks like this was introduced on the last commit on github on the file modules/GOagent/GOagentJS.php Lines: 2541-2542:

$("#DispoSelection").val('A');
DispoSelectSubmit();

Seems like they hard coded this so that as soon as we press hangup button that code is executed and disposes the call as "Answering Machine" I'm not sure if this is a error or has any usefull functionality, but I remove those 2 lines from that file and now my installation works like normal.

Actions #2

Updated by Wittie Manansala about 1 year ago

Hi,

We have confirmed this bug

Thanks for raising this issue and sharing your solution.

Actions #3

Updated by Demian Biscocho about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fix has been posted in Github repo. Thank you!

Actions #4

Updated by rotciv Pepperoni about 1 year ago

Hey, Thank you so much for fixing this fairly quick!

Actions #5

Updated by Wittie Manansala about 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF

Go to top