Project

General

Profile

Bug #4852

Survey Campaign Not Playing Audio File

Added by Amit pandey over 2 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
High
Category:
Bugs
Target version:
-
Start date:
06/01/2017
Due date:
% Done:

0%

Estimated time:

Description

Hi Team,

As i am testing survey campaign on Goautodial 3.3 on E1/PRI Line but couldn't succeed, i created survey campaign after following http://goautodial.org/projects/goautodialce/wiki/Howto_setup_survey_campaign_30.

I checked in forum but nothing found useful.

Uploaded suggested audio format 16bit Mono 8K PCM
Uploaded lead file my number as test number
After activation of Survey campaign call ring to my cell phone but when i answer call get hangup within sec there is no audio file play on call answer.

Call flow is Dialer dial the number and when caller answer the call he will hear the audio file as assigned and hangup.

CLI output

[Jun 1 16:39:04] -- Executing [9920596107@default:1] AGI in new stack
[Jun 1 16:39:04] -- AGI Script Executing Application: (EXEC) Options: (Set(_CAMPCUST=62660204))
[Jun 1 16:39:04] -- <Local/9920596107@default-0000000e;2>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Jun 1 16:39:04] -- Executing [9920596107@default:2] Dial("Local/9920596107@default-0000000e;2", "DAHDI/g1/9920596107,,tTor") in new stack
[Jun 1 16:39:04] -- Requested transfer capability: 0x00 - SPEECH
[Jun 1 16:39:04] -- Called DAHDI/g1/9920596107
[Jun 1 16:39:04] -- DAHDI/i1/9920596107-f is proceeding passing it to Local/9920596107@default-0000000e;2
[Jun 1 16:39:07] Manager 'sendcron' logged on from 127.0.0.1
[Jun 1 16:39:07] Manager 'sendcron' logged off from 127.0.0.1
[Jun 1 16:39:08] -- DAHDI/i1/9920596107-f is ringing
[Jun 1 16:39:08] -- DAHDI/i1/9920596107-f is making progress passing it to Local/9920596107@default-0000000e;2
[Jun 1 16:39:11] -- DAHDI/i1/9920596107-f answered Local/9920596107@default-0000000e;2
[Jun 1 16:39:11] > Channel Local/9920596107@default-0000000e;1 was answered.
[Jun 1 16:39:11] -- Executing [8366@default:1] Playback("Local/9920596107@default-0000000e;1", "sip-silence") in new stack
[Jun 1 16:39:11] == Manager 'sendcron' logged off from 127.0.0.1
[Jun 1 16:39:11] -- <Local/9920596107@default-0000000e;1> Playing 'sip-silence.gsm' (language 'en')
[Jun 1 16:39:11] -- Executing [h@default:1] AGI in new stack
[Jun 1 16:39:11] -- Executing [8366@default:2] AGI in new stack
[Jun 1 16:39:11] -- <DAHDI/i1/9920596107-f>AGI Script agi://127.0.0.1:4577/call_log completed, returning 0
[Jun 1 16:39:11] -- Executing [8366@default:3] AGI in new stack
[Jun 1 16:39:11] -- Launched AGI Script /var/lib/asterisk/agi-bin/agi-VDAD_ALL_outbound.agi
[Jun 1 16:39:12] -- Playing 'sip-silence' (escape_digits=) (sample_offset 0)
[Jun 1 16:39:12] WARNING5330: channel.c:3622 ast_waitfordigit_full: The FD we were waiting for has something waiting. Waitfordigit returning numeric 1
[Jun 1 16:39:12] -- <DAHDI/i1/9920596107-f>AGI Script agi-VDAD_ALL_outbound.agi completed, returning 4
[Jun 1 16:39:12] == Spawn extension (default, 8366, 3) exited non-zero on 'DAHDI/i1/9920596107-f'
[Jun 1 16:39:12] -- Executing [h@default:1] AGI in new stack
[Jun 1 16:39:12] -- <DAHDI/i1/9920596107-f>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----0--------------- completed, returning 0
[Jun 1 16:39:12] -- Hungup 'DAHDI/i1/9920596107-f'
[Jun 1 16:39:12] -- <Local/9920596107@default-0000000e;2>AGI Script agi://127.0.0.1:4577/call_log--HVcauses--PRI-----NODEBUG-----16-----ANSWER-----7-----0 completed, returning 0

As i seen many post and its suggested firewall issue but i think firewall come between when i am using SIP trunk.

History

#1 Updated by OP Chauhan about 2 years ago

Hi,

Check you campaign route extension

For support Skype -optools

#2 Updated by Wittie Manansala about 1 year ago

  • Status changed from New to Rejected

Please use the forums. This issue tracker is for GOautodial development purposes only.

Also available in: Atom PDF

Go to top