Project

General

Profile

EC2 installation

Added by Jorge Cornejo 24 days ago

Hi,
Trying to make a EC2 Instance work but everytime I try to login, I get an error 500...httpd logs show nothing about it.

[Fri Mar 01 18:15:02.741712 2019] [alias:warn] [pid 4020] AH00671: The Alias directive in /etc/httpd
/conf.d/welcome.conf at line 18 will probably never match because it overlaps an earlier Alias.
[Fri Mar 01 18:15:02.741733 2019] [alias:warn] [pid 4020] AH00671: The Alias directive in /etc/httpd
/conf.d/welcome.conf at line 19 will probably never match because it overlaps an earlier Alias.
[Fri Mar 01 18:15:02.741736 2019] [alias:warn] [pid 4020] AH00671: The Alias directive in /etc/httpd
/conf.d/welcome.conf at line 20 will probably never match because it overlaps an earlier Alias.
[Fri Mar 01 18:15:02.741739 2019] [alias:warn] [pid 4020] AH00671: The Alias directive in /etc/httpd
/conf.d/welcome.conf at line 21 will probably never match because it overlaps an earlier Alias.
[Fri Mar 01 18:15:02.741745 2019] [alias:warn] [pid 4020] AH00671: The Alias directive in /etc/httpd
/conf.d/welcome.conf at line 22 will probably never match because it overlaps an earlier Alias.
[Fri Mar 01 18:15:02.767100 2019] [auth_digest:notice] [pid 4020] AH01757: generating secret for dig
est authentication ...
[Fri Mar 01 18:15:02.767677 2019] [lbmethod_heartbeat:notice] [pid 4020] AH02282: No slotmem from mo
d_heartmonitor
[Fri Mar 01 18:15:02.859876 2019] [mpm_prefork:notice] [pid 4020] AH00163: Apache/2.4.6 (CentOS) Ope
nSSL/1.0.2k-fips PHP/7.0.31 configured -- resuming normal operations
[Fri Mar 01 18:15:02.859913 2019] [core:notice] [pid 4020] AH00094: Command line: '/usr/sbin/httpd -
D FOREGROUND'

Also the kamailio.service won't start. Also, logs won't show anything. They are none actually at /var/log/kamailio. The log file is there but no luck.

Any clue what am I missing?
I followed the steps at [[https://goautodial.org/projects/goautodialce/wiki/Version_4_How_To_Install_Goautodial_From_Scratch_using_CentOS_7X]]

Thanks in advance


Replies (7)

RE: EC2 installation - Added by Jorge Cornejo 24 days ago

Running
kamctl start

Returns:

ERROR: PID file /var/run/kamailio/kamailio.pid does not exist

Running
kamailio -M 8 -E -e -dd

database engine 'MYSQL' loaded
Control engine 'RPCFIFO' loaded

INFO: Starting Kamailio :

ERROR: PID file /var/run/kamailio/kamailio.pid does not exist -- Kamailio start failed
[root@edialer1 kamailio]# cd /var/run/kamailio/
[root@edialer1 kamailio]# ls
[root@edialer1 kamailio]# kamailio -M 8 -E -e -dd
 0(6566) INFO: <core> [main.c:1934]: main(): private (per process) memory: 8388608 bytes
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_IP_ADDR!172.31.3.164!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_DOMAIN!vaglxc01.goautodial.com!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_WS_PORT!8080!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_WSS_PORT!4443!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_MSRP_PORT!9080!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_WS_ADDR!tcp:172.31.3.164:8080!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_WSS_ADDR!tls:172.31.3.164:4443!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MY_MSRP_ADDR!tls:172.31.3.164:9080!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MSRP_MIN_EXPIRES!1800!g
 0(6566) INFO: <core> [core/ppcfg.c:82]: pp_subst_add(): ### added subst expression: !MSRP_MAX_EXPIRES!3600!g
loading modules under config path: /usr/lib64/kamailio/modules/
 0(6566) INFO: tls [tls_init.c:497]: init_tls_compression(): tls: init_tls: disabling compression...
 0(6566) INFO: <core> [core/sctp_core.c:75]: sctp_core_check_support(): SCTP API not enabled - if you want to use it, load sctp module
Listening on
             udp: 127.0.0.1:5060
             udp: 172.31.3.164:5060
             tcp: 172.31.3.164:5060
             tcp: 172.31.3.164:8080
             tls: 172.31.3.164:5061
             tls: 172.31.3.164:4443
             tls: 172.31.3.164:9080
Aliases:
             tls: ip-172-31-3-164.sa-east-1.compute.internal:9080
             tls: ip-172-31-3-164.sa-east-1.compute.internal:4443
             tls: ip-172-31-3-164.sa-east-1.compute.internal:5061
             tcp: ip-172-31-3-164.sa-east-1.compute.internal:8080
             tcp: ip-172-31-3-164.sa-east-1.compute.internal:5060
             udp: ip-172-31-3-164.sa-east-1.compute.internal:5060
             udp: localhost4.localdomain4:5060
             udp: localhost4:5060
             udp: localhost.localdomain:5060
             udp: localhost:5060
             *: vaglxc01.goautodial.com:*
             *: 172.31.3.164:*

 0(6566) INFO: <core> [core/tcp_main.c:4671]: init_tcp(): using epoll_lt as the io watch method (auto detected)
 0(6568) INFO: rr [../outbound/api.h:52]: ob_load_api(): unable to import bind_ob - maybe module is not loaded
 0(6568) INFO: rr [rr_mod.c:175]: mod_init(): outbound module not available
 0(6568) INFO: tls [tls_mod.c:365]: mod_init(): With ECDH-Support!
 0(6568) INFO: tls [tls_mod.c:368]: mod_init(): With Diffie Hellman
 0(6568) INFO: cfgutils [cfgutils.c:780]: mod_init(): no hash_file given, disable hash functionality
 0(6568) INFO: pike [pike.c:99]: pike_init(): PIKE - initializing
 0(6568) INFO: pike [ip_tree.c:81]: init_lock_set(): probing 256 set size
 0(6568) INFO: tls [tls_init.c:708]: init_tls_h(): tls: _init_tls_h:  compiled  with  openssl  version "OpenSSL 1.0.2k-fips  26 Jan 2017" (0x100020bf), kerberos support: on, compression: on
 0(6568) INFO: tls [tls_init.c:716]: init_tls_h(): tls: init_tls_h: installed openssl library version "OpenSSL 1.0.2k-fips  26 Jan 2017" (0x100020bf), kerberos support: on,  zlib compression: on
 compiler: gcc -I. -I.. -I../include  -fPIC -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DKRB5_MIT -m64 -DL_ENDIAN -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic -Wa,--noexecstack -DPURIFY -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_MONT5 -DOPENSSL_BN_ASM_GF2m -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM -DVPAES_ASM -DBSAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM -DECP_NISTZ256_ASM
 0(6568) WARNING: tls [tls_init.c:773]: init_tls_h(): tls: openssl bug #1491 (crash/mem leaks on low memory) workaround enabled (on low memory tls operations will fail preemptively) with free memory thresholds 14155776 and 7077888 bytes
 0(6568) INFO: <core> [core/cfg/cfg_ctx.c:608]: cfg_set_now(): INFO: cfg_set_now(): tls.low_mem_threshold1 has been changed to 14155776
 0(6568) INFO: <core> [core/cfg/cfg_ctx.c:608]: cfg_set_now(): INFO: cfg_set_now(): tls.low_mem_threshold2 has been changed to 7077888
 0(6568) ERROR: db_mysql [km_my_con.c:129]: db_mysql_new_connection(): driver error: Access denied for user 'kamailiou'@'localhost' (using password: YES)
 0(6568) ERROR: <core> [db.c:318]: db_do_init2(): could not add connection to the pool 0(6568) ERROR: usrloc [dlist.c:654]: register_udomain(): failed to open database connection
 0(6568) ERROR: registrar [registrar.c:571]: domain_fixup(): failed to register domain
 0(6568) ERROR: <core> [core/route.c:1154]: fix_actions(): fixing failed (code=-1) at cfg:/etc/kamailio/kamailio.cfg:866
 0(6568) ERROR: <core> [core/rvalue.c:3860]: fix_rval_expr(): failure in cfg at line: 866 col: 30
 0(6568) ERROR: <core> [core/rvalue.c:3860]: fix_rval_expr(): failure in cfg at line: 866 col: 30
 0(6568) ERROR: <core> [core/route.c:1154]: fix_actions(): fixing failed (code=-1) at cfg:/etc/kamailio/kamailio.cfg:868
error -1 while trying to fix configuration
 0(6568) INFO: <core> [core/sctp_core.c:53]: sctp_core_destroy(): SCTP API not initialized

RE: EC2 installation - Added by Jorge Cornejo 24 days ago

So, my issue is that databases are not being created.
I have set the mysql root password to vicidialnow.
Installed the RPM via yum
Executed the ./install.sh later

No errors shown anywhere...
How to create the Databases? Are they created by the RPM or by the install script.
I have found the SQL scripts used to initialize so I guess would be done by the install.sh, however, can't find a single line at the script that tries to connect to the DB...
Any ideas?

RE: EC2 installation - Added by Demian Biscocho 23 days ago

Can you try the scratch installation HOWTO again? We just updated it today. And please don't forget to reboot your server/VM.

RE: EC2 installation - Added by Jorge Cornejo 19 days ago

Will do
However, don't see any correction or steps for the MariaBD SQL scripts...is password then intended to be "blank"?

RE: EC2 installation - Added by Jorge Cornejo 19 days ago

Also, any chance that instead of disabling the whole firewall you can post which ports and rules need to be created?
Thanks

RE: EC2 installation - Added by ed dagohoy 4 days ago

for iso use ami

RE: EC2 installation - Added by Jorge Cornejo 3 days ago

Sorry can you please elaborate?

    (1-7/7)
    Go to top