Project

General

Profile

No sound for call waiting

Added by Adam A 11 months ago

Hello,

I succeeded to install Go Autodial v4 following from scratch instructions and started to use it with for outbound campaigns. It is working well but I have the consistent issue for call waiting in step 06 for the classic workflow describes below:
01. Go Autodial robot calling 2 different users A and B
02. Agent picking up call with user A (OK)
03. User B receiving call and picking up. (So User B awaiting start of conversation) (OK)
04. Agent ending call with User A after some time (OK)
05. At call hang up agent put a feedback for call via call status feature (OK)
06. After submitting feedback agent is connected with call waiting User B (NOT OK: Agent cannot hear User B voice and User B cannot hear agent voice)

Could you please help to fix this issue?

Best regards,
Adam.


Replies (6)

RE: No sound for call waiting - Added by maxime seb 11 months ago

It's really interesting, I'm also facing the same bug... I tried to debug on the asterisk/kamailio/rtpengine side but I didn't find anything abnormal...
Of course no firewall !

RE: No sound for call waiting - Added by Carlos Quevedo 11 months ago

I just investigated and the problem occurs when a music on hold resource is used, and then a konference is entered, the audio from the other end is lost. I have installed dadhi + meetme to replace it with the konference and I no longer have audio problems.

RE: No sound for call waiting - Added by Alfred Vilsmeier 7 months ago

Could you please post how do you replace Konference with MeetMe in Dialplan?
Thanks!

RE: No sound for call waiting - Added by Levy Ryan Nolasco 6 months ago

@Alfred
Try the following:

1. Install dahdi
2. Disable app Konference
3. Enable Meetme app
4. Reboot your server.

MeetMe dial plan can be found at extensions.conf while Konference is at extensions-goautodial.conf

RE: No sound for call waiting - Added by Leopoldo Martinez about 1 month ago

Levy Ryan Nolasco wrote in RE: No sound for call waiting:

@Alfred
Try the following:

1. Install dahdi
2. Disable app Konference
3. Enable Meetme app
4. Reboot your server.

MeetMe dial plan can be found at extensions.conf while Konference is at extensions-goautodial.conf

how did you do to install dahdi?
When i tried to do it i got this

[root@inbound asterisk]# yum install dahdi
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                                                                                                  |  15 kB  00:00:00
 * base: centos.mirror.constant.com
 * elrepo: iad.mirror.rackspace.com
 * epel: epel.mirror.constant.com
 * extras: mirror.es.its.nyu.edu
 * updates: mirror.clarkson.edu
base                                                                                                                                  | 3.6 kB  00:00:00
elrepo                                                                                                                                | 3.0 kB  00:00:00
epel                                                                                                                                  | 4.7 kB  00:00:00
extras                                                                                                                                | 2.9 kB  00:00:00
goautodial-current                                                                                                                    | 2.2 kB  00:00:00
goautodial-updates                                                                                                                    | 2.9 kB  00:00:00
updates                                                                                                                               | 2.9 kB  00:00:00
(1/3): epel/x86_64/primary_db                                                                                                         | 6.9 MB  00:00:00
(2/3): epel/x86_64/updateinfo                                                                                                         | 1.0 MB  00:00:00
(3/3): updates/7/x86_64/primary_db                                                                                                    | 8.8 MB  00:00:00
Resolving Dependencies
> Running transaction check
> Package dahdi.x86_64 0:2.10.2-0.el7.centos will be installed
> Processing Dependency: libusb-0.1.so.4()(64bit) for package: dahdi-2.10.2-0.el7.centos.x86_64
> Running transaction check
> Package libusb.x86_64 1:0.1.4-3.el7 will be installed
> Processing Dependency: libusb-1.0.so.0()(64bit) for package: 1:libusb-0.1.4-3.el7.x86_64
> Running transaction check
> Package libusbx.x86_64 0:1.0.21-1.el7 will be installed
> Processing Conflict: dahdi-2.10.2-0.el7.centos.x86_64 conflicts asterisk <= 2009020507:1.6.2.13-0
> Finished Dependency Resolution
Error: dahdi conflicts with asterisk-13.17.2-vici.el7.centos.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

and i can't install dahdi

    (1-6/6)
    Go to top