Project

General

Profile

Nat configuration

Added by Arnaldo Javier 6 months ago

The server within the network works perfectly but, when calling from nat, the softphone receives the call but no audio comes out or comes in and I didn't find the sip_nat.conf


Replies (4)

RE: Nat configuration - Added by Levy Ryan Nolasco 6 months ago

Hi,

Try to add your server IP in carrier settings or sip.conf > externip:YourServerIP

RE: Nat configuration - Added by Arnaldo Javier 6 months ago

Hi,
hello, yes that has already been done but, the problem persists

RE: Nat configuration - Added by Arnaldo Javier 6 months ago

A user outside the local network can call other users (both in the local network and in the Internet), but they can’t hear each other, there is no sound.
If a user outside calls the voicemail he can hear the voicemail menu, but after 20seconds the call is finished by Asterisk, this is what I get from Asterisk:
– Executing [85000@default:1] VoiceMailMain(“SIP/5060-083126d8”, “”) in new stack
– Playing ‘vm-login’ (language ‘en’)
[…]
[May 7 13:01:40] WARNING4750: chan_sip.c:1881 retrans_pkt: Maximum retries exceeded on transmission for seqno 1 (Critical Response)
[May 7 13:01:40] WARNING4750: chan_sip.c:1898 retrans_pkt: Hanging up call - no reply to our critical packet. == Spawn extension (default, 85000, 1) exited non-zero on ‘SIP/5060-083126d8’

When analysign the call with Ethereal I discovered that the SIP messages are correctly interchanged between the user and Asterisk, but the RTP traffic from the useris destinated to the private IP address of Asterisk instead of to its public IP. I think that this is caused because the Asterisk sends a SIP/SDP Status: 200 OK, with session description message to the user and the Connection informations is “IN IP4 192.168.100.150” instead of “IN IP4 puclic.ip.of.asterisk”.

The debug log is attched. 192.168.100.150 is the private IP of Asterisk and !92.50.20.77 is hte privte IP of the VoIP user.

What should I configure to get this scheme work properly?

RE: Nat configuration - Added by Levy Ryan Nolasco 6 months ago

Hi,

You might want to check your iptables eth1 settings if your using eth1 as private NIC, You can also try setting your Private IP on the externip.

    (1-4/4)
    Go to top