Project

General

Profile

Login to Dialer - SSL Error

Added by Linda Rossi 27 days ago

GOAD v4 installed by ISO (correctly and succesfully), verified IP and FQDN in files

/var/www/html/php/goCRMAPISettings.php
/etc/kamailio/kamailio.cfg
/etc/kamailio/tls.cfg
/etc/rtpengine/rtpengine.conf
/etc/asterisk/sip-goautodial.conf

"Login to Dialer" make websock connection error "4443/' failed: Error in connection establishment: net::ERR_CERT_AUTHORITY_INVALID".


Replies (20)

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 25 days ago

Have you restarted Kamailio when you edited /etc/kamailio/tls.cfg for your FQDN SSL certificate?

RE: Login to Dialer - SSL Error - Added by Linda Rossi 24 days ago

yes! same result!

this my tls.cfg:

[server:default]
method = TLSv1
verify_certificate = no
require_certificate = no
private_key = /etc/pki/tls/private/localhost.key
certificate = /etc/pki/tls/certs/localhost.crt

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 22 days ago

Linda Rossi wrote:

"Login to Dialer" make websock connection error "4443/' failed: Error in connection establishment: net::ERR_CERT_AUTHORITY_INVALID".

Looks like your SSL certificate is not valid for your FQDN. Is this self generated? Have you tried reverting back to the default install and dialing from there?

RE: Login to Dialer - SSL Error - Added by Linda Rossi 22 days ago

i have followed the "GOautodial v4 Getting Started Guide", with custom FQDN and custom ip address, more than one time

but nothing!

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 21 days ago

Try doing it without your FQDN. Based from the error messages, that's where the problem lies. Afterwards, we can help you step by step on how to use your FQDN.

RE: Login to Dialer - SSL Error - Added by Linda Rossi 21 days ago

i have tried one more time with steps:

- install v4 iso (without OS update)
- custom only ip address
- create user
- create campaign
- create list
- agent login

but same result!

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 17 days ago

Can you post the contents of "goCRMsettings.php":

cat /var/www/html/php/goCRMsettings.php

Can you also post the screenshot of your webRTC settings page?

RE: Login to Dialer - SSL Error - Added by Linda Rossi 16 days ago

this my /var/www/html/php/goCRMsettings.php:

define ('gourl', 'https://192.168.0.31/goAPIv2');
define ('goUser', 'goAPI');
define ('responsetype', 'json');

?>

in attach, webrtc settings

RE: Login to Dialer - SSL Error - Added by Wittie Manansala 15 days ago

Hi,

Try to check kamailio service.

service kamailio status

if its failed try to run this:
service kamailio restart

And try to login.

Thanks

RE: Login to Dialer - SSL Error - Added by Linda Rossi 15 days ago

kamailio is active (in attach)

RE: Login to Dialer - SSL Error - Added by Wittie Manansala 14 days ago

Now try to create a new user or agent and try to login. If still an error please provide us asterisk CLI log.

Thanks

RE: Login to Dialer - SSL Error - Added by Linda Rossi 14 days ago

create "agent002" and login, but nothing

in attach, ERR_CERT_AUTHORITY_INVALID and asterisk CLI

RE: Login to Dialer - SSL Error - Added by Linda Rossi 14 days ago

no error in asterisk CLI

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 14 days ago

Can you attach the following files?

/etc/kamailio/kamailio.cfg
/etc/kamailio/tls.cfg

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 10 days ago

Everything looks good on the config files. Not really sure why you're getting "4443/' failed: Error in connection establishment: net::ERR_CERT_AUTHORITY_INVALID".

RE: Login to Dialer - SSL Error - Added by Linda Rossi 10 days ago

is it only mine issue?!?! :-((

RE: Login to Dialer - SSL Error - Added by Linda Rossi 10 days ago

have you tried with your new recent iso installation?!

RE: Login to Dialer - SSL Error - Added by Demian Biscocho 9 days ago

That's correct. We can't replicate the issue you're having even with a new install via ISO.

RE: Login to Dialer - SSL Error - Added by Linda Rossi 9 days ago

solved! it's depend of antivirus, SSL/TLS control!

    (1-20/20)
    Go to top