Goautodial 3.0 "404 not found" when accessing Static IP

Added by Tyler Coon over 4 years ago

I have just installed Goautodial 3.0 and followed the directions to the T. I have installed many previous versions of Vicidial, Goautodial, VicidialNow, and Vicibox.

Only thing I have edited so far is the network settings, setting the IP to: 192.168.1.2. I have a linksys RV042 router and have setup that router to DMZ the .2 to our static IP address of: *****.

I can ping the server from outside the network, and I know that it is hitting the goautodial server because it automatically forwards to /login/ like it should. However, it says "404 Not Found" when it redirects to /login/ and when I simply type in ****, it says "No Data Received" in google chrome.

I have turned off all firewalls (In goautodial and in my router) so that isn't the issue. I can pull up the panel just fine when I connect directly to the router and type in 192.168.1.2. I updated the IP settings on goautodial and really don't know what else to do. Please let me know what I have to do from this point, I'm sure it's something small and easy. Thank you!! :)


Replies (7)

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tristan Kendrick Biscocho over 4 years ago

Are you trying to access your web login using the public IP on the same Local network? or are you on a different network? Do you have your own static IP address provided by your ISP or are you on DHCP?

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tyler Coon over 4 years ago

Hey Tristan!

I am accessing it on a separate network, and yes I have a static IP address provided by the IP Address.

Like I said, I know it's hitting the server because it automatically redirects to /login/.

I did run the yum update directly after install. All IP Settings look fine, machine is able to ping out to google.com, and I am able to ping the machine from outside the network.

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tyler Coon over 4 years ago

Also it shows the same way other goautodial 3.0 servers show with the SSL Certificate not authenticating correctly so it is definitely hitting the server.

Capture.PNG (32.3 kB)

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tristan Kendrick Biscocho over 4 years ago

Hi,

Have you tried running setup on your goautodial server? Run setup > network configuration > edit devices > your LAN card > fill the appropriate fields.

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tristan Kendrick Biscocho over 4 years ago

Hi,

Forgot to mention that you need to run update_ip script ( /usr/share/astguiclient/ADMIN_update_server_ip.pl) after configuring your server ip.

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tyler Coon over 4 years ago

I already have my server set up as the .2, and ran the update_server_ip script. Please understand that this is about my 40th dialer install and will have done all the normal things. If you check my attachment, you will see that it IS forwarding to the server. Simply that instead of showing the goautodial login screen, it shows a 404 not found screen. When I access the dialer on the local network through the .2 it works and goes directly to the login page and can login just fine.

RE: Goautodial 3.0 "404 not found" when accessing Static IP - Added by Tristan Kendrick Biscocho over 4 years ago

Hi, disregard my previous post. TOtally forgot you had a static ip address. sorry.

(1-7/7)